summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-08-13 03:55:52 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-08-13 03:56:22 +0300
commitc9307b1333310e9fe9474483bdf8b806c2d1537b (patch)
tree7a8a3b347d43aa2b4a72e11f20b67dc1f4e32c09
parentf6083e4cfd2b9d5cdcd94c58a40b08f3ad8eb33d (diff)
downloadgentoo-c9307b1333310e9fe9474483bdf8b806c2d1537b.tar.gz
gentoo-c9307b1333310e9fe9474483bdf8b806c2d1537b.tar.xz
net-p2p/qbittorrent: version bump (v4.1.2)
- switch to autotools as cmake is not supported officially Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 1e782c2dc82..5e42163e06f 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.0.4.tar.xz 4279752 BLAKE2B 6385040d1179814e3290fb1c7b2d1e0b5782144663d12a067c43a2d8a47d0f0cfc0633c69f183db70eab2591ef100f39b07ea2d5e3cbca3a4d149ccb70e4d838 SHA512 ead0a306242d883673e13f9e6dc5ad83d4624c3d7ffb586aff78c03f7685e89b6a6c8640fff6a1b251565892178d37f4a64d45d0ce18935a212ca39302a28969
DIST qbittorrent-4.1.1.tar.gz 7464014 BLAKE2B be005fbecd1d2c9ee977fbdc6782bbad9708e3c2c6d46deb5831ae4e7457954cb95ae87850b759e81e87e345ca682acfcd23684b7704c437c4261ebb5bb46f5d SHA512 700c084b97556ba85276b42e46f77d5f7896052ce02ba052cd4b3e6967c8a848c27bcf63a289bf8276b38841bb9a80b9ec16335c3feb30dce0851170f54d101e
+DIST qbittorrent-4.1.2.tar.gz 7697135 BLAKE2B 13e9456fd43395d597156519bdd665db898d462761dc5fe5f92e40994e8d0e214b0a1f9d8d327d44f8deb287c646c7013c17099bca193d85d1a3b2d851ada976 SHA512 25293378693cec875d1b52ea5aca8087a0d31021e6fbb4bd31f05c6979e36a5dc03983f2007a067942e1e119878b94a9e2b9622f324c7592f6630dcfe008b757
diff --git a/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild b/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild
new file mode 100644
index 00000000000..3740a5f02ff
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.1.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org/
+ https://github.com/qbittorrent/qBittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5(+),X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf --with-qtsingleapplication=system \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}