summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-08-24 13:07:56 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-08-24 13:54:26 +0100
commit989094927eb9d90cac212c037c893172e310a11a (patch)
tree3dba80c2857c5632c46586d3195e169ff64f7c8f
parent6fb5e93b556791003c030a6011aa97ddb98a9a90 (diff)
downloadgentoo-989094927eb9d90cac212c037c893172e310a11a.tar.gz
gentoo-989094927eb9d90cac212c037c893172e310a11a.tar.xz
app-portage/hackport: bump up to 0.5.6
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--app-portage/hackport/Manifest1
-rw-r--r--app-portage/hackport/hackport-0.5.6.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-portage/hackport/Manifest b/app-portage/hackport/Manifest
index e5e4a599ec2..91dea67d8f0 100644
--- a/app-portage/hackport/Manifest
+++ b/app-portage/hackport/Manifest
@@ -3,3 +3,4 @@ DIST hackport-0.5.2.tar.gz 1390418 BLAKE2B d9d90e86d16532a04fb387ba4d0aa3e53594d
DIST hackport-0.5.3.tar.gz 1390724 BLAKE2B 666a1bbb4f5eb4abf6a5546867bbfdaf2280bcd2967773b3b57c2933f44e7a367127cd4b56c6d0cf300c3ae30bd6a066e02dd976dc962ecaa39316d70cbe937b SHA512 785a1fb9762bdd10e86f47255d687a905eb122eb46e9470b7ea562cbe98d1be882b28923d5852f41ba2481c27321de9b2322fc83b5fa77037ba9251ea5f08dcc
DIST hackport-0.5.4.tar.gz 1390924 BLAKE2B 2fcc4ece84b813e130d860048328b7c4b704f1a37cffe15f26f24f8a9db8e7a267f083b1f8469f1d3e9753c07ad17dbbc209a2a8095770a7610fe73baf9965c1 SHA512 49593066608bf8d57678d1725c51da4f1f6213a06b1c5645d97e4a711704adc9a40c66ad4fd6a624572fc7491943874b5b48381bc02545a0e9b6d7a5619be073
DIST hackport-0.5.5.tar.gz 1618493 BLAKE2B 939f0ef89c7bbc4117d6222e8c8d813883a02d1277466477f3ff1910ebaba418969ff4e8c170a6dae8888394254790aeb69ecc69b36e01c9f341663938aa39b5 SHA512 b91fe72884ccc3a6acb79115ba8f8418250e13f102a07542e3d06db3880b572c73d2d4b5c05622eee83af3715f3a854d2cf7142ebb92627d8b332db4152d817d
+DIST hackport-0.5.6.tar.gz 1639896 BLAKE2B 2c5892b3206b4cbb10f8dcbce1d043446b7b804ae0b5d1e59c49c733c80194e79c9091cfc933cbc7e7a592c0747ee034d56969d4261ad0a6a585259d5e8b4f76 SHA512 5dc20f11392757224a6cf79d525792e14aba64ffb44c9dd9b4f0df4acd9c00127d85f2b1f23cf2063f80895dbcc90ccc745e8f9aba3ef82f7ae8364db155fe4f
diff --git a/app-portage/hackport/hackport-0.5.6.ebuild b/app-portage/hackport/hackport-0.5.6.ebuild
new file mode 100644
index 00000000000..cc57aa98f59
--- /dev/null
+++ b/app-portage/hackport/hackport-0.5.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="http://hackage.haskell.org/package/hackport"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests are broken: need path to ebuild tree
+
+RDEPEND="
+ || (
+ <sys-apps/portage-2.3.0
+ sys-apps/portage-mgorny
+ app-portage/repoman
+ )
+ dev-haskell/async:=
+ dev-haskell/base16-bytestring:=
+ dev-haskell/base64-bytestring:=
+ dev-haskell/cryptohash:=
+ dev-haskell/ed25519:=
+ dev-haskell/extensible-exceptions:=
+ dev-haskell/hashable:=
+ >=dev-haskell/http-4000.0.3:=
+ dev-haskell/missingh:=
+ dev-haskell/mtl:=
+ >=dev-haskell/network-2.6:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ dev-haskell/old-time:=
+ dev-haskell/parsec:=
+ dev-haskell/random:=
+ dev-haskell/regex-compat:=
+ dev-haskell/split:=
+ dev-haskell/stm:=
+ >=dev-haskell/tar-0.5:=
+ >=dev-haskell/xml-1.3.7:=
+ dev-haskell/zlib:=
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit )
+"
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}