summaryrefslogtreecommitdiff
path: root/app-emulation/spice
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-08-07 23:53:08 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-08-07 23:53:08 -0500
commitabf075427a45a3832c0faffd6431df108c0815fb (patch)
treeabeb0b77cb25830e16aad740245e8f6d9536a27c /app-emulation/spice
parent43c8b26be09026f899652915c868e32313d09f39 (diff)
downloadgentoo-abf075427a45a3832c0faffd6431df108c0815fb.tar.gz
gentoo-abf075427a45a3832c0faffd6431df108c0815fb.tar.xz
app-emulation/spice: work around access violation during configure, bug #586560
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation/spice')
-rw-r--r--app-emulation/spice/spice-0.12.7-r1.ebuild4
-rw-r--r--app-emulation/spice/spice-0.13.1-r2.ebuild4
-rw-r--r--app-emulation/spice/spice-9999.ebuild4
3 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/spice/spice-0.12.7-r1.ebuild b/app-emulation/spice/spice-0.12.7-r1.ebuild
index c5145606a23..cecdd6ec20e 100644
--- a/app-emulation/spice/spice-0.12.7-r1.ebuild
+++ b/app-emulation/spice/spice-0.12.7-r1.ebuild
@@ -39,6 +39,10 @@ DEPEND="
smartcard? ( app-emulation/qemu[smartcard] )
${RDEPEND}"
+# Prevent sandbox violations, bug #586560
+# https://bugzilla.gnome.org/show_bug.cgi?id=581836
+addpredict /dev
+
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"
diff --git a/app-emulation/spice/spice-0.13.1-r2.ebuild b/app-emulation/spice/spice-0.13.1-r2.ebuild
index 960c1c9e8c1..80cf44adb64 100644
--- a/app-emulation/spice/spice-0.13.1-r2.ebuild
+++ b/app-emulation/spice/spice-0.13.1-r2.ebuild
@@ -41,6 +41,10 @@ DEPEND="
smartcard? ( app-emulation/qemu[smartcard] )
${RDEPEND}"
+# Prevent sandbox violations, bug #586560
+# https://bugzilla.gnome.org/show_bug.cgi?id=581836
+addpredict /dev
+
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index f93c735ded1..03693f6d7c1 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -41,6 +41,10 @@ DEPEND="
smartcard? ( app-emulation/qemu[smartcard] )
${RDEPEND}"
+# Prevent sandbox violations, bug #586560
+# https://bugzilla.gnome.org/show_bug.cgi?id=581836
+addpredict /dev
+
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"