summaryrefslogtreecommitdiff
path: root/app-text/htmldoc
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-06 01:54:34 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-06 01:54:50 -0400
commit99a82a0bd419f480a90583865acbf5926be3abd3 (patch)
tree775cf4e0f1ed7fca2db3f3d765d104828a74d4bc /app-text/htmldoc
parente2cc5603f10be39b25575e53ab3c327c083bb522 (diff)
downloadgentoo-99a82a0bd419f480a90583865acbf5926be3abd3.tar.gz
gentoo-99a82a0bd419f480a90583865acbf5926be3abd3.tar.xz
app-text/htmldoc: new version 1.8.30.
This new version makes use of the DSTROOT build system variable, avoiding the need to patch in DESTDIR everywhere. It also fixes some more installation paths to avoid moving things around in src_install, and avoids a (now-pointless) sed on the LIBS variable. Gentoo-Bug: 615208 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/htmldoc')
-rw-r--r--app-text/htmldoc/Manifest1
-rw-r--r--app-text/htmldoc/htmldoc-1.8.30.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
index db40799ac30..8df11ba658f 100644
--- a/app-text/htmldoc/Manifest
+++ b/app-text/htmldoc/Manifest
@@ -1 +1,2 @@
DIST htmldoc-1.8.29-source.tar.bz2 4089227 SHA256 e8c96ad740d19169eab8305c8e2ee1c795c4afa59ba99d18786ad191a2853f31 SHA512 06c4367b84005624564dfb33d2cc632cbfc711268ffce9efe00c17760da17637949fc7415fd29fcd63edc26ba96ff18cf57d1e9d36e7205b92ac2095cf4acfc8 WHIRLPOOL 3efe016ce4e071d164e3ca44fe3c8cba9ba830eb0847215116fbccab45b7ae913bfe94c723d4c8ba952c48ce31c68e5c4a71bd7048030a03c8fb3dffe42ea6d3
+DIST htmldoc-1.8.30-source.tar.gz 3901592 SHA256 7fb7a532f590f7ce1b7c8486d9fe30adaea3c7c32cb412ba7cf093d67cba5fc6 SHA512 713dc67622533dae896745ac8809e43a7f91696715aeb77df2628bd04c0d3e16c8402891499e8e0c10cab793b44114e600d5935b3c76a3cfa303c10897456804 WHIRLPOOL 873cc5785bc295197e8461214f02279b6225b9ea07345a86e855341abc5a827aeef0c715b4c77ed8a74028e2a5a61ae6b0412055c09cbe39a92be54764561d7f
diff --git a/app-text/htmldoc/htmldoc-1.8.30.ebuild b/app-text/htmldoc/htmldoc-1.8.30.ebuild
new file mode 100644
index 00000000000..6d672ebc0ad
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.8.30.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+HOMEPAGE="http://www.msweet.org/projects.php?Z1"
+SRC_URI="https://github.com/michaelrsweet/${PN}/releases/download/v${PV}/${P}-source.tar.gz"
+IUSE="fltk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=media-libs/libpng-1.4:0=
+ virtual/jpeg:0
+ fltk? ( x11-libs/fltk:1 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # make sure not to use the libs htmldoc ships with
+ rm -r jpeg png zlib || die 'failed to unbundle jpeg, png, and zlib'
+
+ # Fix the documentation path in a few places. Some Makefiles aren't
+ # autotoolized =(
+ for file in configure doc/Makefile doc/htmldoc.man; do
+ sed -i "${file}" \
+ -e "s:/doc/htmldoc:/doc/${PF}/html:g" \
+ || die "failed to fix documentation path in ${file}"
+ done
+}
+
+src_configure() {
+ CC=$(tc-getCC) CXX=$(tc-getCXX) DSTROOT="${D}" econf $(use_with fltk gui)
+}
+
+src_install() {
+ emake DSTROOT="${D}" install
+}