summaryrefslogtreecommitdiff
path: root/dev-embedded
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-20 14:54:11 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-20 14:54:11 +0200
commitb0a0afe7a3509e2eb3699fa9cf37278465cc5b5a (patch)
tree7626dcf078500113528d73fb206d8d382fdf2826 /dev-embedded
parentc626dc0aff41cfbdc424bb6b156561c3dfcd88ad (diff)
downloadgentoo-b0a0afe7a3509e2eb3699fa9cf37278465cc5b5a.tar.gz
gentoo-b0a0afe7a3509e2eb3699fa9cf37278465cc5b5a.tar.xz
dev-embedded/gputils: Remove 0.13.6-r1
Uses deprecated EAPI 0 and overshadowed by 1.5.0. Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/gputils/Manifest1
-rw-r--r--dev-embedded/gputils/files/gputils-0.13.6-code_pack.patch182
-rw-r--r--dev-embedded/gputils/gputils-0.13.6-r1.ebuild31
3 files changed, 0 insertions, 214 deletions
diff --git a/dev-embedded/gputils/Manifest b/dev-embedded/gputils/Manifest
index 4dc19cff7e4..6095093be79 100644
--- a/dev-embedded/gputils/Manifest
+++ b/dev-embedded/gputils/Manifest
@@ -1,4 +1,3 @@
-DIST gputils-0.13.6.tar.gz 2042890 BLAKE2B 234534c227c1a56a4a23ec27f3cf436ed3a5bad0860bbae008866294039f6d3543266a97a424dade4501e41a78f831d2092544f91923290d84e9726f8810b820 SHA512 e5227863c2f103db133102d526fd60d08f306f0ca8cf4b1f951616e8cf72264912394fa51375734c006d48bbe1adf8038347c35d8401f15ec5cfe906008f212d
DIST gputils-0.13.7.tar.gz 2670129 BLAKE2B df1978105d679d930b5d1707b9db5b833baea83d196ae1861c08b89726bebafe9f14521233634561f5beb72cc05fc4670faeff4353e518b40877c63b85075303 SHA512 4133a0281c125abb964d2451bfff422444f9816ebb4c17dcc8faa88829e7a84d6cb542cfb9acda397ef9f14a1979644fbcf29aa489cdf94fb6e26c99b2ee901b
DIST gputils-0.14.0.tar.gz 2802791 BLAKE2B 34c5da263a3a3bc1e24b85e03c9169e8e563742583eb34becd62bd9934a44238ff41ac95cb7c05bc552ee2b23110c178c5e87db4adc929e85699a471bfa07d5b SHA512 ca50c95fc81043f8672db0d5101831de65a536ce8e5061aabedfa340f821bc7eb6db7bea6f8923b239167ed65a17b1fe7d32d40e10e69b92d351ba408535f1d4
DIST gputils-0.14.1.tar.gz 3233430 BLAKE2B 16e9442636f525c936f81a02537732833184100d120ec9bff509fa362fb48753f3fbfd33053504e48b1933a701cd4a00129ced77c740bb83bdfc667db765ff5d SHA512 e32b7628377390a491b3455a7c5c89cf29b8dd4928f450c879d4d9de4416536265198346ba5b5fad073ac03c33af879ab8acc0a6d6d4713d5ef8c3ea94a4c4dd
diff --git a/dev-embedded/gputils/files/gputils-0.13.6-code_pack.patch b/dev-embedded/gputils/files/gputils-0.13.6-code_pack.patch
deleted file mode 100644
index f743ec343f6..00000000000
--- a/dev-embedded/gputils/files/gputils-0.13.6-code_pack.patch
+++ /dev/null
@@ -1,182 +0,0 @@
-Index: gpasm/lst.c
-===================================================================
---- gpasm/lst.c (revision 541)
-+++ gpasm/lst.c (revision 542)
-@@ -212,11 +212,75 @@
- }
- }
-
-+unsigned int lst_data(char *m, unsigned int byte_org,
-+ unsigned int bytes_emitted, size_t sizeof_m)
-+{
-+ char buf[BUFSIZ];
-+ unsigned int i;
-+ unsigned int lst_bytes = 0;
-+
-+ if ((byte_org & 1) != 0) {
-+ /* not word-aligned */
-+ /* list first byte */
-+ unsigned char emit_byte = (unsigned char)(i_memory_get(state.i_memory,
-+ (byte_org >> 1)) >> 8);
-+ snprintf(buf, sizeof(buf), "%02X", emit_byte);
-+ strncat(m, buf, sizeof_m);
-+ ++lst_bytes;
-+ /* list whole words */
-+ for (i = 0; (i < ((bytes_emitted-1) >> 1)) && (i < 1); ++i) {
-+ unsigned int emit_word = i_memory_get(state.i_memory,
-+ ((byte_org+1) >> 1) + i) & 0xffff;
-+ snprintf(buf, sizeof(buf), "%02X %02X", emit_word & 0x00ff,
-+ emit_word >> 8);
-+ strncat(m, buf, sizeof_m);
-+ lst_bytes += 2;
-+ }
-+ /* list extra byte if odd */
-+ if (((byte_org+bytes_emitted) & 1) != 0) {
-+ snprintf(buf, sizeof(buf), "%02X ", i_memory_get(state.i_memory,
-+ ((byte_org + bytes_emitted - 2) >> 1)) & 0x00ff);
-+ strncat(m, buf, sizeof_m);
-+ ++lst_bytes;
-+ }
-+ else {
-+ strncat(m, " ", sizeof_m);
-+ }
-+ }
-+ else { /* word-aligned */
-+ /* list full words as bytes */
-+ for (i = 0; (i < (bytes_emitted >> 1)) && (i < 2); ++i) {
-+ unsigned int emit_word = i_memory_get(state.i_memory,
-+ (byte_org>>1) + i) & 0xffff;
-+ snprintf(buf, sizeof(buf), "%04X ", emit_word);
-+ strncat(m, buf, sizeof_m);
-+ lst_bytes += 2;
-+ }
-+ if (bytes_emitted < 4) {
-+ /* list extra byte if odd */
-+ if (((byte_org+bytes_emitted) & 1) != 0) {
-+ snprintf(buf, sizeof(buf), "%02X ", i_memory_get(state.i_memory,
-+ (byte_org+bytes_emitted)>>1) & 0x00ff);
-+ strncat(m, buf, sizeof_m);
-+ ++lst_bytes;
-+ }
-+ else {
-+ strncat(m, " ", sizeof_m);
-+ }
-+ }
-+ }
-+
-+ return lst_bytes;
-+}
-+
- void lst_format_line(char *src_line, int value)
- {
- char m[BUFSIZ];
- char buf[BUFSIZ];
- unsigned int emitted = 0;
-+ unsigned int byte_org = 0;
-+ unsigned int bytes_emitted = 0;
-+ unsigned int lst_bytes;
-
- assert(src_line != NULL);
-
-@@ -239,41 +303,21 @@
- state.device.id_location + 1) & 0xffff);
- break;
- case insn:
-- emitted = state.org - state.lst.line.was_org
-- + (state.obj.section &&
-- state.obj.section->emitted_pack_byte ? 1 : 0);
-- snprintf(m, sizeof(m), "%04X ", (state.lst.line.was_org << _16bit_core)
-- - (state.obj.section &&
-- ((emitted == 0 &&
-- state.obj.section->have_pack_byte) ||
-- state.obj.section->emitted_pack_byte) ? 1 : 0));
-+ byte_org = (state.lst.line.was_org << 1);
-+ if (state.obj.section)
-+ byte_org -= (state.obj.section->emitted_pack_byte ? 1 : 0);
-+ bytes_emitted = (state.org << 1) - byte_org;
-+ if (state.obj.section)
-+ bytes_emitted -= (state.obj.section->have_pack_byte ? 1 : 0);
-+ emitted = (bytes_emitted >> 1);
-+ if (((byte_org & 1) == 0) && ((bytes_emitted & 1) != 0))
-+ emitted += 1;
-+ snprintf(m, sizeof(m), "%04X ", byte_org >> (1 - _16bit_core));
-
-- if (emitted >= 1) {
-- if(state.obj.section && state.obj.section->have_pack_byte && emitted == 1)
-- snprintf(buf, sizeof(buf), "%02X ", i_memory_get(state.i_memory, state.lst.line.was_org) & 0xff);
-- else if(state.obj.section && state.obj.section->emitted_pack_byte)
-- snprintf(buf, sizeof(buf), " %02X ", (i_memory_get(state.i_memory, state.lst.line.was_org - 1) & 0xff00) >> 8);
-- else
-- snprintf(buf, sizeof(buf), "%04X ", i_memory_get(state.i_memory,
-- state.lst.line.was_org) & 0xffff);
-+ lst_bytes = lst_data(m, byte_org, bytes_emitted, sizeof(m));
-+ byte_org += lst_bytes;
-+ bytes_emitted -= lst_bytes;
-
-- strncat(m, buf, sizeof(m));
-- } else
-- strncat(m, " ", sizeof(m));
--
-- if (emitted >= 2) {
-- if(state.obj.section && state.obj.section->have_pack_byte && emitted == 2)
-- snprintf(buf, sizeof(buf), "%02X ", i_memory_get(state.i_memory,
-- state.lst.line.was_org
-- + (state.obj.section->emitted_pack_byte ? 0 : 1)) & 0xffff);
-- else
-- snprintf(buf, sizeof(buf), "%04X ", i_memory_get(state.i_memory,
-- state.lst.line.was_org
-- + (state.obj.section &&
-- state.obj.section->emitted_pack_byte ? 0 : 1)) & 0xffff);
-- strncat(m, buf, sizeof(buf));
-- } else
-- strncat(m, " ", sizeof(m));
- break;
- case config:
- if(_16bit_core) {
-@@ -376,39 +420,16 @@
- lst_line(m);
- }
-
-- if (emitted > 2) {
-- int i;
-+ if (bytes_emitted > 0) {
-+ while (bytes_emitted > 0) {
-+ /* data left to print on separate lines */
-
-- for (i = 2; i < emitted; i += 2) {
-- unsigned int org = state.lst.line.was_org + i -
-- (state.obj.section && state.obj.section->emitted_pack_byte ? 1 : 0);
--
-- if ((i + 1) < emitted)
-- if(state.obj.section && state.obj.section->have_pack_byte)
-- snprintf(m, sizeof(m), "%04X %04X %02X ",
-- org << _16bit_core,
-- i_memory_get(state.i_memory, org) & 0xffff,
-- i_memory_get(state.i_memory, org + 1) & 0xff);
-- else
-- snprintf(m, sizeof(m), "%04X %04X %04X",
-- org << _16bit_core,
-- i_memory_get(state.i_memory, org) & 0xffff,
-- i_memory_get(state.i_memory, org + 1) & 0xffff);
-- else {
-- if(state.obj.section && state.obj.section->have_pack_byte)
-- snprintf(m, sizeof(m), "%04X %02X ",
-- ((state.lst.line.was_org + i) << _16bit_core),
-- i_memory_get(state.i_memory,
-- state.lst.line.was_org + i) & 0xff);
-- else
-- snprintf(m, sizeof(m), "%04X %04X",
-- ((state.lst.line.was_org + i) << _16bit_core),
-- i_memory_get(state.i_memory,
-- state.lst.line.was_org + i) & 0xffff);
-- }
-+ strncpy(m, " ", sizeof(m));
-+ lst_bytes = lst_data(m, byte_org, bytes_emitted, sizeof(m));
-+ byte_org += lst_bytes;
-+ bytes_emitted -= lst_bytes;
- lst_line(m);
- }
--
- state.cod.emitting = 0;
- }
-
diff --git a/dev-embedded/gputils/gputils-0.13.6-r1.ebuild b/dev-embedded/gputils/gputils-0.13.6-r1.ebuild
deleted file mode 100644
index 2e47afd1056..00000000000
--- a/dev-embedded/gputils/gputils-0.13.6-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils
-
-DESCRIPTION="Tools including assembler, linker and librarian for PIC microcontrollers"
-HOMEPAGE="http://gputils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-code_pack.patch
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/gputils.ps
- insinto /usr/share/doc/${PF}/
- doins doc/gputils.pdf
-}