summaryrefslogtreecommitdiff
path: root/dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-06 23:18:59 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-06-07 23:20:48 +0100
commitf0015b889d42d7eb947dd4d7140400d6e34ebf1a (patch)
treebef245905c06c2e360c30913ed52f016e17002ee /dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild
parent10d4c9eefbbab6ba9ff99d6ec85bd09b76d349e2 (diff)
downloadgentoo-f0015b889d42d7eb947dd4d7140400d6e34ebf1a.tar.gz
gentoo-f0015b889d42d7eb947dd4d7140400d6e34ebf1a.tar.xz
dev-erlang/riakc: Add new package
It is debundled from net-im/ejabberd-16.04 and therefore inherits keywords from ejabberd: ~amd64, ~arm, ~ppc and ~x86. ~ia64 and ~sparc are not inherited because other dependency is missing these keywords and there's no chance it can get them any time soon. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild')
-rw-r--r--dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild b/dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild
new file mode 100644
index 00000000000..9205f71b1e7
--- /dev/null
+++ b/dev-erlang/riakc/riakc-2.1.1_p20151111.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang clients for Riak"
+HOMEPAGE="https://github.com/basho/riak-erlang-client"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DEPEND=">=dev-erlang/riak_pb-2.1.0.7
+ >=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ # 'priv' directory contains only edoc.css, but doc isn't going to be built.
+ rm -r "${S}/priv"
+}