summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 13:08:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 13:09:19 +0200
commit1298dc2cd43472dc1a6cef1018c050864c77eecc (patch)
tree13f2601b96d7fc7a9c31afb50aac8bc6c1597440 /dev-python
parentad539da6c5db4da30260d1c5ac441ad714fe0e8c (diff)
downloadgentoo-1298dc2cd43472dc1a6cef1018c050864c77eecc.tar.gz
gentoo-1298dc2cd43472dc1a6cef1018c050864c77eecc.tar.xz
Drop deprecated usage of DISTUTILS_NO_PARALLEL_BUILD
Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/behave/behave-1.2.4.ebuild2
-rw-r--r--dev-python/bokeh/bokeh-0.7.1.ebuild2
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild2
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild2
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild1
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.1.ebuild1
-rw-r--r--dev-python/httpretty/httpretty-0.7.0.ebuild1
-rw-r--r--dev-python/mamba/mamba-0.6.ebuild2
-rw-r--r--dev-python/mamba/mamba-0.8.4.ebuild2
-rw-r--r--dev-python/oslotest/oslotest-1.3.0.ebuild2
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild1
-rw-r--r--dev-python/rdflib/rdflib-3.2.3-r1.ebuild1
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild1
-rw-r--r--dev-python/reportlab/reportlab-2.6.ebuild2
-rw-r--r--dev-python/reportlab/reportlab-3.1.44-r1.ebuild2
-rw-r--r--dev-python/requests-mock/requests-mock-0.5.1.ebuild2
-rw-r--r--dev-python/requests-mock/requests-mock-0.6.0.ebuild2
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild2
18 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/behave/behave-1.2.4.ebuild b/dev-python/behave/behave-1.2.4.ebuild
index 5fc06dfd8a6..af692e7840f 100644
--- a/dev-python/behave/behave-1.2.4.ebuild
+++ b/dev-python/behave/behave-1.2.4.ebuild
@@ -40,8 +40,6 @@ python_compile_all() {
python_test() {
nosetests || die "nosetests failed under ${EPYTHON}"
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
distutils_install_for_testing
diff --git a/dev-python/bokeh/bokeh-0.7.1.ebuild b/dev-python/bokeh/bokeh-0.7.1.ebuild
index 06993090ae6..cf10e0e5019 100644
--- a/dev-python/bokeh/bokeh-0.7.1.ebuild
+++ b/dev-python/bokeh/bokeh-0.7.1.ebuild
@@ -60,8 +60,6 @@ DOCS=( CHANGELOG QUICKSTART.md README.md )
PATCHES=( "${FILESDIR}"/${P}-setup.patch )
-DISTUTILS_NO_PARALLEL_BUILD=1
-
python_prepare_all() {
DOC_CONTENTS="websockets work only with python2_7"
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
index 280e6fe8bb4..dedf7eb4c4e 100644
--- a/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.2.ebuild
@@ -23,8 +23,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
>=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
-# for testsuite
-DISTUTILS_NO_PARALLEL_BUILD=1
# This time half the doc files are missing; Do you want them? toss a coin
python_test() {
diff --git a/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild b/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
index ab2ca0440e3..bf9d347ffe7 100644
--- a/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
+++ b/dev-python/dogpile-cache/dogpile-cache-0.5.4.ebuild
@@ -24,8 +24,6 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
>=dev-python/dogpile-core-0.4.1[${PYTHON_USEDEP}] )"
-# for testsuite
-DISTUTILS_NO_PARALLEL_BUILD=1
# This time half the doc files are missing; Do you want them? toss a coin
python_test() {
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
index 578b6883f78..55853764511 100644
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.5.ebuild
@@ -19,7 +19,6 @@ IUSE=""
# distutils.command.config writes to CWD, bug #450516
# mxSetup.py is broken with --build-lib
#DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_NO_PARALLEL_BUILD=1
python_prepare_all() {
# Don't install documentation in site-packages directories.
diff --git a/dev-python/flask-testing/flask-testing-0.4.1.ebuild b/dev-python/flask-testing/flask-testing-0.4.1.ebuild
index 981b65aaca5..b2f393400ee 100644
--- a/dev-python/flask-testing/flask-testing-0.4.1.ebuild
+++ b/dev-python/flask-testing/flask-testing-0.4.1.ebuild
@@ -29,7 +29,6 @@ DEPEND="${RDEPEND}
)"
S="${WORKDIR}/${MY_P}"
-DISTUTILS_NO_PARALLEL_BUILD=1
python_test() {
nosetests || die "Testing failed with ${EPYTHON}"
diff --git a/dev-python/httpretty/httpretty-0.7.0.ebuild b/dev-python/httpretty/httpretty-0.7.0.ebuild
index 0f0aef593df..bfa5322829f 100644
--- a/dev-python/httpretty/httpretty-0.7.0.ebuild
+++ b/dev-python/httpretty/httpretty-0.7.0.ebuild
@@ -29,7 +29,6 @@ RDEPEND="dev-python/urllib3[${PYTHON_USEDEP}]
# I believe we don't need unpackaged package markment
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} )"
-DISTUTILS_NO_PARALLEL_BUILD=1
PATCHES=( "${FILESDIR}"/${P}-deps.patch )
diff --git a/dev-python/mamba/mamba-0.6.ebuild b/dev-python/mamba/mamba-0.6.ebuild
index bb85f66ee45..f48b226a702 100644
--- a/dev-python/mamba/mamba-0.6.ebuild
+++ b/dev-python/mamba/mamba-0.6.ebuild
@@ -44,8 +44,6 @@ python_prepare_all() {
}
python_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
distutils_install_for_testing
diff --git a/dev-python/mamba/mamba-0.8.4.ebuild b/dev-python/mamba/mamba-0.8.4.ebuild
index 72dd8a4455a..525c7fbabb9 100644
--- a/dev-python/mamba/mamba-0.8.4.ebuild
+++ b/dev-python/mamba/mamba-0.8.4.ebuild
@@ -45,8 +45,6 @@ python_prepare_all() {
}
python_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
distutils_install_for_testing
diff --git a/dev-python/oslotest/oslotest-1.3.0.ebuild b/dev-python/oslotest/oslotest-1.3.0.ebuild
index 7c26156ec7f..31caf8acb00 100644
--- a/dev-python/oslotest/oslotest-1.3.0.ebuild
+++ b/dev-python/oslotest/oslotest-1.3.0.ebuild
@@ -52,8 +52,6 @@ python_compile_all() {
}
python_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -rf .testrepository || die "coudln't remove '.testrepository' under ${EPYTHON}"
testr init || die "testr init failed under ${EPYTHON}"
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 78856a7c547..7aef3ea9988 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -7,7 +7,6 @@ EAPI=5
# pypy: bug #458558 (wrong linker options due to not respecting CC)
PYTHON_COMPAT=( python2_7 )
DISTUTILS_IN_SOURCE_BUILD=1
-DISTUTILS_NO_PARALLEL_BUILD=1
inherit distutils-r1 git-2 multilib
diff --git a/dev-python/rdflib/rdflib-3.2.3-r1.ebuild b/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
index d5c7fc80340..1a4e73004f5 100644
--- a/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
+++ b/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
@@ -6,7 +6,6 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
inherit distutils-r1
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
index 594989ce49e..1a24551a2c4 100644
--- a/dev-python/rdflib/rdflib-4.1.2.ebuild
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -6,7 +6,6 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE="sqlite?"
-DISTUTILS_NO_PARALLEL_BUILD=true
# The usual required for tests
DISTUTILS_IN_SOURCE_BUILD=1
diff --git a/dev-python/reportlab/reportlab-2.6.ebuild b/dev-python/reportlab/reportlab-2.6.ebuild
index a08bbb62ae8..1606664c3eb 100644
--- a/dev-python/reportlab/reportlab-2.6.ebuild
+++ b/dev-python/reportlab/reportlab-2.6.ebuild
@@ -25,8 +25,6 @@ RDEPEND="virtual/python-imaging
DEPEND="${RDEPEND}
app-arch/unzip"
-DISTUTILS_NO_PARALLEL_BUILD=1
-
src_unpack() {
unpack ${P}.tar.gz
cd ${P}/src/reportlab/fonts || die
diff --git a/dev-python/reportlab/reportlab-3.1.44-r1.ebuild b/dev-python/reportlab/reportlab-3.1.44-r1.ebuild
index ab1363217e9..4028999f391 100644
--- a/dev-python/reportlab/reportlab-3.1.44-r1.ebuild
+++ b/dev-python/reportlab/reportlab-3.1.44-r1.ebuild
@@ -32,8 +32,6 @@ DEPEND="${RDEPEND}
app-arch/unzip
"
-DISTUTILS_NO_PARALLEL_BUILD=1
-
src_unpack() {
unpack ${P}.tar.gz
cd ${P}/src/reportlab/fonts || die
diff --git a/dev-python/requests-mock/requests-mock-0.5.1.ebuild b/dev-python/requests-mock/requests-mock-0.5.1.ebuild
index dd11a40202d..f4f89c81e48 100644
--- a/dev-python/requests-mock/requests-mock-0.5.1.ebuild
+++ b/dev-python/requests-mock/requests-mock-0.5.1.ebuild
@@ -32,8 +32,6 @@ RDEPEND="
"
python_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
testr init || die "testr init failed under ${EPYTHON}"
diff --git a/dev-python/requests-mock/requests-mock-0.6.0.ebuild b/dev-python/requests-mock/requests-mock-0.6.0.ebuild
index 93b1c01cefb..b00b333a6d7 100644
--- a/dev-python/requests-mock/requests-mock-0.6.0.ebuild
+++ b/dev-python/requests-mock/requests-mock-0.6.0.ebuild
@@ -33,8 +33,6 @@ RDEPEND="
"
python_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=TRUE
-
rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
testr init || die "testr init failed under ${EPYTHON}"
diff --git a/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
index 3a8ad7e160d..282cce2e3d5 100644
--- a/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
@@ -33,8 +33,6 @@ DEPEND="${RDEPEND}
>=dev-python/nose-0.10.4[${PYTHON_USEDEP}]
)"
-# py26 tests needs
-DISTUTILS_NO_PARALLEL_BUILD=1
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${PN}-0.7-logging.handlers.patch" )