summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-11-02 17:04:46 -0500
committerAustin English <wizardedit@gentoo.org>2016-11-11 13:38:57 -0600
commitd12b75fa62a5f5230c4624cf142b845ccedfa66d (patch)
treeae61ab3fc1b0a3dcd73f6c509b81aeea665077d7 /games-engines
parentd0b0de80d631027926a8dab52d7f60a2e0f57f88 (diff)
downloadgentoo-d12b75fa62a5f5230c4624cf142b845ccedfa66d.tar.gz
gentoo-d12b75fa62a5f5230c4624cf142b845ccedfa66d.tar.xz
games-engines/frotz: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.2
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch4
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch4
-rw-r--r--games-engines/frotz/frotz-2.43-r1.ebuild53
3 files changed, 57 insertions, 4 deletions
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
index 71760cc8fa4..3f2639ec47d 100644
--- a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
+++ b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
@@ -1,5 +1,5 @@
---- src/dumb/dumb_input.c
-+++ src/dumb/dumb_input.c
+--- a/src/dumb/dumb_input.c
++++ b/src/dumb/dumb_input.c
@@ -79,7 +79,7 @@
/* Read one line, including the newline, into s. Safely avoids buffer
* overruns (but that's kind of pointless because there are several
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
index 16a0df362ed..c8b4e35eee2 100644
--- a/games-engines/frotz/files/frotz-2.43-ldflags.patch
+++ b/games-engines/frotz/files/frotz-2.43-ldflags.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2010-10-04 14:13:37.000000000 +0200
-+++ Makefile 2010-10-04 14:14:06.000000000 +0200
+--- a/Makefile 2010-10-04 14:13:37.000000000 +0200
++++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
@@ -162,7 +162,7 @@
$(NAME): $(NAME)-curses
diff --git a/games-engines/frotz/frotz-2.43-r1.ebuild b/games-engines/frotz/frotz-2.43-r1.ebuild
new file mode 100644
index 00000000000..c805a5453b8
--- /dev/null
+++ b/games-engines/frotz/frotz-2.43-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Curses based interpreter for Z-code based text games"
+HOMEPAGE="http://frotz.sourceforge.net/"
+SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa oss"
+
+DEPEND="sys-libs/ncurses:0
+ alsa? ( oss? ( media-libs/alsa-oss ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc2.10.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC /d' \
+ Makefile \
+ || die
+}
+
+src_compile() {
+ local OPTS="CONFIG_DIR=/etc"
+ use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
+ emake ${OPTS} all
+}
+
+src_install () {
+ dobin {d,}frotz
+ doman doc/*.6
+ dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
+ doc/{frotz.conf-big,frotz.conf-small}
+}
+
+pkg_postinst() {
+ echo
+ elog "Global config file can be installed in /etc/frotz.conf"
+ elog "Sample config files are in /usr/share/doc/${PF}"
+ echo
+}