summaryrefslogtreecommitdiff
path: root/games-strategy/0ad
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/0ad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/0ad')
-rw-r--r--games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild141
-rw-r--r--games-strategy/0ad/0ad-0.0.17_alpha.ebuild144
-rw-r--r--games-strategy/0ad/Manifest2
-rw-r--r--games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch42
-rw-r--r--games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch93
-rw-r--r--games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch100
-rw-r--r--games-strategy/0ad/metadata.xml20
7 files changed, 542 insertions, 0 deletions
diff --git a/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild b/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild
new file mode 100644
index 00000000000..2c1be9796bc
--- /dev/null
+++ b/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils games
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://play0ad.com/"
+SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby pch sound test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/spidermonkey:24
+ dev-libs/boost
+ dev-libs/icu:=
+ dev-libs/libxml2
+ ~games-strategy/0ad-data-${PV}
+ media-gfx/nvidia-texture-tools
+ media-libs/libpng:0
+ media-libs/libsdl[X,opengl,video]
+ net-libs/enet:1.3
+ net-libs/miniupnpc
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+ lobby? ( net-libs/gloox )
+ sound? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/openal )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-gcc-4.9.patch
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-nvtt
+ --with-system-enet
+ --with-system-miniupnpc
+ --with-system-mozjs24
+ --minimal-flags
+ $(usex pch "" "--without-pch")
+ $(usex test "" "--without-tests")
+ $(usex sound "" "--without-audio")
+ $(usex editor "--atlas" "")
+ $(usex lobby "" "--without-lobby")
+ --collada
+ --bindir="${GAMES_BINDIR}"
+ --libdir="$(games_get_libdir)"/${PN}
+ --datadir="${GAMES_DATADIR}"/${PN}
+ )
+
+ # stock premake4 does not work, use the shipped one
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # regenerate scripts.c so our patch applies
+ cd "${S}"/build/premake/premake4 || die
+ "${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+ # rebuild premake again... this is the most stupid build system
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # run premake to create build scripts
+ cd "${S}"/build/premake || die
+ "${S}"/build/premake/premake4/bin/release/premake4 \
+ --file="premake4.lua" \
+ --outpath="../workspaces/gcc/" \
+ --platform=$(usex amd64 "x64" "x32") \
+ --os=linux \
+ "${myconf[@]}" \
+ gmake || die "Premake failed"
+}
+
+src_compile() {
+ # build 3rd party fcollada
+ emake -C libraries/source/fcollada/src
+
+ # build 0ad
+ emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+ cd binaries/system || die
+ ./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+ dogamesbin binaries/system/pyrogenesis
+ use editor && dogamesbin binaries/system/ActorEditor
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r binaries/data/l10n
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe binaries/system/libCollada.so
+ use editor && doexe binaries/system/libAtlasUI.so
+
+ dodoc binaries/system/readme.txt
+ doicon -s 128 build/resources/${PN}.png
+ games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
+ use editor &&
+ games_make_wrapper ${PN}-ActorEditor "${GAMES_BINDIR}/ActorEditor"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/0ad/0ad-0.0.17_alpha.ebuild b/games-strategy/0ad/0ad-0.0.17_alpha.ebuild
new file mode 100644
index 00000000000..c50a5329833
--- /dev/null
+++ b/games-strategy/0ad/0ad-0.0.17_alpha.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils games
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://play0ad.com/"
+SRC_URI="mirror://sourceforge/zero-ad/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby nvtt pch sound test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/spidermonkey:24[-icu]
+ dev-libs/boost
+ dev-libs/icu:=
+ dev-libs/libxml2
+ ~games-strategy/0ad-data-${PV}
+ media-libs/libpng:0
+ media-libs/libsdl2[X,opengl,video]
+ net-libs/enet:1.3
+ net-libs/miniupnpc
+ net-misc/curl
+ sys-libs/zlib
+ virtual/jpeg
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+ lobby? ( net-libs/gloox )
+ nvtt? ( media-gfx/nvidia-texture-tools )
+ sound? ( media-libs/libvorbis
+ media-libs/openal )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+ local myconf=(
+ --with-system-nvtt
+ --with-system-miniupnpc
+ --with-system-mozjs24
+ --minimal-flags
+ --sdl2
+ $(usex nvtt "" "--without-nvtt")
+ $(usex pch "" "--without-pch")
+ $(usex test "" "--without-tests")
+ $(usex sound "" "--without-audio")
+ $(usex editor "--atlas" "")
+ $(usex lobby "" "--without-lobby")
+ --collada
+ --bindir="${GAMES_BINDIR}"
+ --libdir="$(games_get_libdir)"/${PN}
+ --datadir="${GAMES_DATADIR}"/${PN}
+ )
+
+ # stock premake4 does not work, use the shipped one
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # regenerate scripts.c so our patch applies
+ cd "${S}"/build/premake/premake4 || die
+ "${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+ # rebuild premake again... this is the most stupid build system
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+ emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+ # run premake to create build scripts
+ cd "${S}"/build/premake || die
+ "${S}"/build/premake/premake4/bin/release/premake4 \
+ --file="premake4.lua" \
+ --outpath="../workspaces/gcc/" \
+ --platform=$(usex amd64 "x64" "x32") \
+ --os=linux \
+ "${myconf[@]}" \
+ gmake || die "Premake failed"
+}
+
+src_compile() {
+ # build 3rd party fcollada
+ emake -C libraries/source/fcollada/src
+
+ # build 0ad
+ emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+ cd binaries/system || die
+ ./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+ dogamesbin binaries/system/pyrogenesis
+ use editor && dogamesbin binaries/system/ActorEditor
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r binaries/data/l10n
+
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe binaries/system/libCollada.so
+ use editor && doexe binaries/system/libAtlasUI.so
+
+ dodoc binaries/system/readme.txt
+ doicon -s 128 build/resources/${PN}.png
+ games_make_wrapper ${PN} "${GAMES_BINDIR}/pyrogenesis"
+ use editor &&
+ games_make_wrapper ${PN}-ActorEditor "${GAMES_BINDIR}/ActorEditor"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ einfo
+ elog "It is advised to compile dev-lang/spidermonkey with the"
+ elog "jit USE flag enabled! Otherwise you might experience slowdowns."
+ einfo
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
new file mode 100644
index 00000000000..6ff61256669
--- /dev/null
+++ b/games-strategy/0ad/Manifest
@@ -0,0 +1,2 @@
+DIST 0ad-0.0.16-alpha-unix-build.tar.xz 20019680 SHA256 cb965ef7e292bc3a2f1f598a9695e16ff4d786398f384a1ec7d5f9bfe2626de5 SHA512 9fe3440233d9827895b91ade1873afe977d62386a5dd6042d8169b153d576b462381bfc97e637f0b183aff034236380ca6d552ea2755cf08398143ad67121031 WHIRLPOOL 0e2f1ac9799a4b4d4588c2370a78195f2cc415fb2043be815ed2a2f9f179ccd856c405e7c0323f2033d3a6a4d63c08d8d5c8a05b50769ae3b9219717218edef6
+DIST 0ad-0.0.17-alpha-unix-build.tar.xz 19327284 SHA256 ef144d44fe8a8abd29a4642999a58a596b8f0d0e1f310065f5ce1dfbe29c3aeb SHA512 21133b7f255df73909e0ba72d455ed8d687cdca4a6d28fb04fb2a786ee941d7f4e207b5c245f9bfff1f3e5e10e2ccc932f49587e227982885eef64b4114d02c6 WHIRLPOOL 662e177293ca7add73ca160b67a526aeda6a7a32e26a68fb577376d25db00df9844fe763a2dfcef70f66fc0edd6d2297158251a517deeaa7d7e8292850a8b444
diff --git a/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch b/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
new file mode 100644
index 00000000000..5b17120b4f7
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.16_alpha-gcc-4.9.patch
@@ -0,0 +1,42 @@
+Index: /ps/trunk/source/lib/allocators/headerless.cpp
+===================================================================
+--- /ps/trunk/source/lib/allocators/headerless.cpp (revision 15333)
++++ /ps/trunk/source/lib/allocators/headerless.cpp (revision 15334)
+@@ -55,10 +55,12 @@
+ }
+
+- FreedBlock(uintptr_t id, size_t size)
+- : m_magic(s_magic), m_size(size), m_id(id)
+- {
+- }
+-
+- ~FreedBlock()
++ void Setup(uintptr_t id, size_t size)
++ {
++ m_magic = s_magic;
++ m_size = size;
++ m_id = id;
++ }
++
++ void Reset()
+ {
+ // clear all fields to prevent accidental reuse
+@@ -411,6 +413,7 @@
+ FreedBlock* WriteTags(u8* p, size_t size)
+ {
+- FreedBlock* freedBlock = new(p) FreedBlock(s_headerId, size);
+- (void)new(Footer(freedBlock)) FreedBlock(s_footerId, size);
++ FreedBlock* freedBlock = (FreedBlock*)p;
++ freedBlock->Setup(s_headerId, size);
++ Footer(freedBlock)->Setup(s_footerId, size);
+
+ m_freeBlocks++;
+@@ -431,6 +434,6 @@
+
+ FreedBlock* footer = Footer(freedBlock);
+- freedBlock->~FreedBlock();
+- footer->~FreedBlock();
++ freedBlock->Reset();
++ footer->Reset();
+ }
+
diff --git a/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch
new file mode 100644
index 00000000000..30192fbccd5
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.16_alpha-gentoo.patch
@@ -0,0 +1,93 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Jun 24 18:32:38 UTC 2012
+Subject: build system
+
+respect flags
+let stripping be handled by the system
+
+fix minimal-flags option:
+ leave -fvisibility=hidden active
+ leave conditional -fpc-preprocess active
+
+--- build/premake/premake4.lua
++++ build/premake/premake4.lua
+@@ -145,7 +145,7 @@
+
+ function project_set_build_flags()
+
+- flags { "Symbols", "NoEditAndContinue" }
++ flags { "NoEditAndContinue" }
+ if not _OPTIONS["icc"] and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
+ -- adds the -Wall compiler flag
+ flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
+@@ -337,13 +337,11 @@
+ end
+ end
+
+- if not _OPTIONS["minimal-flags"] then
+ buildoptions {
+ -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
+ -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
+ "-fvisibility=hidden"
+ }
+- end
+
+ if _OPTIONS["bindir"] then
+ defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
+--- libraries/source/fcollada/src/Makefile
++++ libraries/source/fcollada/src/Makefile
+@@ -9,8 +9,8 @@
+
+ CXX ?= g++
+ CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
+-CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
+-CXXFLAGS_RELEASE := -O1 -DNDEBUG -DRETAIL
++CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
++CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
+ # (-O2 with gcc 4.3 causes linker errors when using this library, for unknown reasons, so stick with -O1 until gcc >4.3 is typical.)
+ CXXFLAGS_TEST := -O0 -g -D_DEBUG
+ LIBS += `pkg-config libxml-2.0 --libs`
+--- build/premake/premake4/src/tools/gcc.lua
++++ build/premake/premake4/src/tools/gcc.lua
+@@ -136,8 +136,6 @@
+ if not cfg.flags.Symbols then
+ if cfg.system == "macosx" then
+ table.insert(result, "-Wl,-x")
+- else
+- table.insert(result, "-s")
+ end
+ end
+
+--- build/premake/premake4/build/gmake.unix/Premake4.make
++++ build/premake/premake4/build/gmake.unix/Premake4.make
+@@ -26,9 +26,9 @@
+ DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -Os
+- CXXFLAGS += $(CPPFLAGS) -Wall -Os
+- LDFLAGS += -s -rdynamic
++ CFLAGS += $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CPPFLAGS) -Wall
++ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+ LDDEPS +=
+@@ -48,8 +48,8 @@
+ DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -g
+- CXXFLAGS += $(CPPFLAGS) -Wall -g
++ CFLAGS += $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CPPFLAGS) -Wall
+ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+@@ -302,4 +302,4 @@
+ $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"
+
+ -include $(OBJECTS:%.o=%.d)
+--include $(GCH:%.h.gch=%.h.d)
+\ No newline at end of file
++-include $(GCH:%.h.gch=%.h.d)
diff --git a/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch
new file mode 100644
index 00000000000..45233ab1606
--- /dev/null
+++ b/games-strategy/0ad/files/0ad-0.0.17_alpha-gentoo.patch
@@ -0,0 +1,100 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Jun 24 18:32:38 UTC 2012
+Subject: build system
+
+respect flags
+let stripping be handled by the system
+
+fix minimal-flags option:
+ leave -fvisibility=hidden active
+ leave conditional -fpc-preprocess active
+
+--- build/premake/premake4.lua
++++ build/premake/premake4.lua
+@@ -177,7 +177,7 @@
+
+ function project_set_build_flags()
+
+- flags { "Symbols", "NoEditAndContinue" }
++ flags { "NoEditAndContinue" }
+ if cc ~= "icc" and (os.is("windows") or not _OPTIONS["minimal-flags"]) then
+ -- adds the -Wall compiler flag
+ flags { "ExtraWarnings" } -- this causes far too many warnings/remarks on ICC
+@@ -366,13 +366,11 @@
+ end
+ end
+
+- if not _OPTIONS["minimal-flags"] then
+- buildoptions {
+- -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
+- -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
+- "-fvisibility=hidden"
+- }
+- end
++ buildoptions {
++ -- Hide symbols in dynamic shared objects by default, for efficiency and for equivalence with
++ -- Windows - they should be exported explicitly with __attribute__ ((visibility ("default")))
++ "-fvisibility=hidden"
++ }
+
+ if _OPTIONS["bindir"] then
+ defines { "INSTALLED_BINDIR=" .. _OPTIONS["bindir"] }
+--- libraries/source/fcollada/src/Makefile
++++ libraries/source/fcollada/src/Makefile
+@@ -9,9 +9,9 @@
+
+ CXX ?= g++
+ CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
+-CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
+-CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
+-CXXFLAGS_TEST := -O0 -g -D_DEBUG
++CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
++CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
++CXXFLAGS_TEST := -D_DEBUG
+ LIBS += `pkg-config libxml-2.0 --libs`
+ INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
+ INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
+--- build/premake/premake4/src/tools/gcc.lua
++++ build/premake/premake4/src/tools/gcc.lua
+@@ -136,8 +136,6 @@
+ if not cfg.flags.Symbols then
+ if cfg.system == "macosx" then
+ table.insert(result, "-Wl,-x")
+- else
+- table.insert(result, "-s")
+ end
+ end
+
+--- build/premake/premake4/build/gmake.unix/Premake4.make
++++ build/premake/premake4/build/gmake.unix/Premake4.make
+@@ -26,9 +26,9 @@
+ DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -Os
+- CXXFLAGS += $(CPPFLAGS) -Wall -Os
+- LDFLAGS += -s -rdynamic
++ CFLAGS += $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CPPFLAGS) -Wall
++ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+ LDDEPS +=
+@@ -48,8 +48,8 @@
+ DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) -Wall -g
+- CXXFLAGS += $(CPPFLAGS) -Wall -g
++ CFLAGS += $(CPPFLAGS) -Wall
++ CXXFLAGS += $(CPPFLAGS) -Wall
+ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+@@ -302,4 +302,4 @@
+ $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"
+
+ -include $(OBJECTS:%.o=%.d)
+--include $(GCH:%.h.gch=%.h.d)
+\ No newline at end of file
++-include $(GCH:%.h.gch=%.h.d)
diff --git a/games-strategy/0ad/metadata.xml b/games-strategy/0ad/metadata.xml
new file mode 100644
index 00000000000..b0120ff5c7d
--- /dev/null
+++ b/games-strategy/0ad/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <use>
+ <flag name="editor">Include Atlas scenario editor projects</flag>
+ <flag name="lobby">Enable the use of <pkg>net-libs/gloox</pkg>
+ and the multiplayer lobby</flag>
+ <flag name="nvtt">Support for some uncompressed data formats
+ via <pkg>media-gfx/nvidia-texture-tools</pkg>
+ (might be needed for some mods)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">zero-ad</remote-id>
+ </upstream>
+</pkgmetadata>