summaryrefslogtreecommitdiff
path: root/mail-client
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-09-07 16:29:40 -0400
committerIan Stakenvicius <axs@gentoo.org>2015-09-07 16:31:58 -0400
commit1602509da7c0b88c9a22ef15bde49c91566eaa8e (patch)
tree688b9fdaf990adec68916869c79456e152354f27 /mail-client
parent514f72a3500d571c4333ebf7424d6e0c68603b25 (diff)
downloadgentoo-1602509da7c0b88c9a22ef15bde49c91566eaa8e.tar.gz
gentoo-1602509da7c0b88c9a22ef15bde49c91566eaa8e.tar.xz
firefox,thunderbird: Ensure $SHELL gets set to something
Zero_Chaos noticed when building firefox within catalyst that failures would occur due to the build system not finding the correct shell. It was determined this was due to catalyst not setting SHELL in the environment, which resulted in the firefox build system being passed SHELL="" and causing the failure. This commit ensures SHELL will never be empty by hard-coding /bin/bash (EPREFIX'd when appropriate) if there is no SHELL specified in the environment. Changed ebuilds: www-client/firefox-38.2.1 www-client/firefox-40.0.3 mail-client/thunderbird-38.2.0 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-38.2.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/mail-client/thunderbird/thunderbird-38.2.0.ebuild b/mail-client/thunderbird/thunderbird-38.2.0.ebuild
index f7f9b9e6f67..c7a4cf98c7a 100644
--- a/mail-client/thunderbird/thunderbird-38.2.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-38.2.0.ebuild
@@ -244,7 +244,7 @@ src_compile() {
mkdir -p "${BUILD_OBJ_DIR}" && cd "${BUILD_OBJ_DIR}" || die
CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
- MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL}" \
+ MOZ_MAKE_FLAGS="${MAKEOPTS}" SHELL="${SHELL:-${EPREFIX%/}/bin/bash}" \
emake -f "${S}"/client.mk
# Only build enigmail extension if crypt enabled.