summaryrefslogtreecommitdiff
path: root/media-sound/mac
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/mac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/mac')
-rw-r--r--media-sound/mac/Manifest1
-rw-r--r--media-sound/mac/mac-3.99.4.5.7-r1.ebuild55
-rw-r--r--media-sound/mac/metadata.xml9
3 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/mac/Manifest b/media-sound/mac/Manifest
new file mode 100644
index 00000000000..9e3e6d78b52
--- /dev/null
+++ b/media-sound/mac/Manifest
@@ -0,0 +1 @@
+DIST mac-3.99-u4-b5-s7.tar.gz 450981 SHA256 9a735af2c56f05ee06b6e2ff719e902271299adf9e25cd3c9e4b28e8df3e30c5 SHA512 fa7ca8cec0ba6c0fb78dda6e964b17e9331184fed656a2458d0e3ac12fc375a661adfd36c142ef63111f31c6b63e8c00fe40e7babe84f0cefe5433940be628e0 WHIRLPOOL f4df5bccad06b7313348e9be734e926c1d511a2e3ca40162bc2c6a8cffb38c1455543fd7dc0a2352efa91945ae5546364085bd05888e906eb9e1c49fde7f743d
diff --git a/media-sound/mac/mac-3.99.4.5.7-r1.ebuild b/media-sound/mac/mac-3.99.4.5.7-r1.ebuild
new file mode 100644
index 00000000000..f0b8f1d2d78
--- /dev/null
+++ b/media-sound/mac/mac-3.99.4.5.7-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic versionator
+
+MY_PV=$(version_format_string '$1.$2-u$3-b$4')
+PATCH=s$(get_version_component_range 5)
+MY_P=${PN}-${MY_PV}-${PATCH}
+
+DESCRIPTION="Monkey's Audio Codecs"
+HOMEPAGE="http://etree.org/shnutils/shntool/"
+SRC_URI="http://etree.org/shnutils/shntool/support/formats/ape/unix/${MY_PV}-${PATCH}/${MY_P}.tar.gz"
+
+LICENSE="mac"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+RDEPEND=""
+DEPEND="sys-apps/sed
+ cpu_flags_x86_mmx? ( dev-lang/yasm )"
+
+S=${WORKDIR}/${MY_P}
+
+RESTRICT="mirror"
+
+src_prepare() {
+ sed -i -e 's:-O3::' configure || die
+}
+
+pkg_setup() {
+ append-cppflags -DSHNTOOL
+ use cpu_flags_x86_mmx && append-ldflags -Wl,-z,noexecstack
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_mmx assembly)
+}
+
+src_install() {
+ default
+
+ insinto /usr/include/${PN}
+ doins src/MACLib/{BitArray,UnBitArrayBase,Prepare}.h #409435
+
+ dodoc ChangeLog.shntool src/*.txt
+ dohtml src/Readme.htm
+
+ prune_libtool_files --all
+}
diff --git a/media-sound/mac/metadata.xml b/media-sound/mac/metadata.xml
new file mode 100644
index 00000000000..1d564b87f11
--- /dev/null
+++ b/media-sound/mac/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+</pkgmetadata>