summaryrefslogtreecommitdiff
path: root/media-sound/qtmpc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/qtmpc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/qtmpc')
-rw-r--r--media-sound/qtmpc/Manifest1
-rw-r--r--media-sound/qtmpc/files/qtmpc-0.6.1-underlinking.patch40
-rw-r--r--media-sound/qtmpc/metadata.xml6
-rw-r--r--media-sound/qtmpc/qtmpc-0.6.1.ebuild24
4 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/qtmpc/Manifest b/media-sound/qtmpc/Manifest
new file mode 100644
index 00000000000..7bd73a6afcc
--- /dev/null
+++ b/media-sound/qtmpc/Manifest
@@ -0,0 +1 @@
+DIST QtMPC-0.6.1.tar.bz2 96341 SHA256 82287a26788b36d49db26518b66203f332cf686eefb81ee2d9be095e61123a62
diff --git a/media-sound/qtmpc/files/qtmpc-0.6.1-underlinking.patch b/media-sound/qtmpc/files/qtmpc-0.6.1-underlinking.patch
new file mode 100644
index 00000000000..881187d1f9c
--- /dev/null
+++ b/media-sound/qtmpc/files/qtmpc-0.6.1-underlinking.patch
@@ -0,0 +1,40 @@
+diff -ruN QtMPC-0-vanilla/CMakeLists.txt QtMPC/CMakeLists.txt
+--- QtMPC-0-vanilla/CMakeLists.txt 2010-11-02 17:00:58.000000000 +0100
++++ QtMPC/CMakeLists.txt 2011-11-20 23:27:18.000000000 +0100
+@@ -81,6 +81,11 @@
+
+ # this command finds Qt4 libraries and sets all required variables
+ FIND_PACKAGE( Qt4 REQUIRED )
++
++# add some useful macros and variables
++# (QT_USE_FILE is a variable defined by FIND_PACKAGE( Qt4 ) that contains a path to CMake script)
++INCLUDE( ${QT_USE_FILE} )
++
+ FIND_PACKAGE( KDE4 )
+
+ IF( NOT DEFINED WANT_KDE_SUPPORT )
+@@ -134,12 +139,6 @@
+ ADD_DEFINITIONS( -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -Wall -Wextra )
+ ENDIF( NOT ENABLE_KDE_SUPPORT )
+
+-# add some useful macros and variables
+-# (QT_USE_FILE is a variable defined by FIND_PACKAGE( Qt4 ) that contains a path to CMake script)
+-IF( NOT ENABLE_KDE_SUPPORT )
+- INCLUDE( ${QT_USE_FILE} )
+-ENDIF( NOT ENABLE_KDE_SUPPORT )
+-
+ ADD_SUBDIRECTORY( external/libmaia )
+
+ # Compile the resource files
+@@ -169,9 +168,9 @@
+
+ # Last but not least, link everything. Based on whether we are using KDE or not.
+ IF( ENABLE_KDE_SUPPORT )
+- TARGET_LINK_LIBRARIES( QtMPC ${QT_LIBRARIES} ${KDE4_KDECORE_LIBS} ${KDE4_KDEUI_LIBS} Maia )
++ TARGET_LINK_LIBRARIES( QtMPC Maia ${KDE4_KDECORE_LIBS} ${KDE4_KDEUI_LIBS} ${QT_LIBRARIES} )
+ ELSE( ENABLE_KDE_SUPPORT )
+- TARGET_LINK_LIBRARIES( QtMPC ${QT_LIBRARIES} Maia )
++ TARGET_LINK_LIBRARIES( QtMPC Maia ${QT_LIBRARIES} )
+ ENDIF( ENABLE_KDE_SUPPORT )
+
+ IF( ENABLE_KDE_SUPPORT )
diff --git a/media-sound/qtmpc/metadata.xml b/media-sound/qtmpc/metadata.xml
new file mode 100644
index 00000000000..721dd1c8d2f
--- /dev/null
+++ b/media-sound/qtmpc/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
+
diff --git a/media-sound/qtmpc/qtmpc-0.6.1.ebuild b/media-sound/qtmpc/qtmpc-0.6.1.ebuild
new file mode 100644
index 00000000000..e5062fe1858
--- /dev/null
+++ b/media-sound/qtmpc/qtmpc-0.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="QtMPC-${PV}"
+inherit kde4-base
+
+DESCRIPTION="Qt MPD client with a tree view music library interface"
+HOMEPAGE="http://lowblog.nl/category/qtmpc/"
+SRC_URI="http://files.lowblog.nl/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/QtMPC"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )