summaryrefslogtreecommitdiff
path: root/net-analyzer
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-17 07:10:37 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-17 07:11:40 +0200
commit1b83413ccdfc7b363fb230d16a469eee4b65822c (patch)
tree6480c9221cc725ad01bf91a51a35c884b0a99f85 /net-analyzer
parent60c0d3815d75aeefe04ec2cbc039fb618b4a02ff (diff)
downloadgentoo-1b83413ccdfc7b363fb230d16a469eee4b65822c.tar.gz
gentoo-1b83413ccdfc7b363fb230d16a469eee4b65822c.tar.xz
net-analyzer/nodebrain: Add live ebuild.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nodebrain/nodebrain-9999.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/nodebrain/nodebrain-9999.ebuild b/net-analyzer/nodebrain/nodebrain-9999.ebuild
new file mode 100644
index 00000000000..c27ee0d59ed
--- /dev/null
+++ b/net-analyzer/nodebrain/nodebrain-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils git-r3
+
+DESCRIPTION="Monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+EGIT_REPO_URI="https://github.com/trettevik/nodebrain-nb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+CDEPEND="
+ dev-libs/libedit
+"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.14-include.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_install() {
+ default
+
+ dodoc -r AUTHORS ChangeLog NEWS README THANKS sample/ html/
+
+ prune_libtool_files
+}