summaryrefslogtreecommitdiff
path: root/net-wireless
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-01-29 09:55:12 +0000
committerTony Vroon <chainsaw@gentoo.org>2018-01-29 09:55:12 +0000
commita2dfb50194b70d205c86c8c4809a1e45a46b0f7a (patch)
tree318d858c21d61b06abc7e678317ec960c11b933b /net-wireless
parent7cafe7fd31229004aeb055a79ed772979e34a8dd (diff)
downloadgentoo-a2dfb50194b70d205c86c8c4809a1e45a46b0f7a.tar.gz
gentoo-a2dfb50194b70d205c86c8c4809a1e45a46b0f7a.tar.xz
net-wireless/wireless-regdb: regulatory.db support
As reported by Mike Lothian in bug #643520 and implemented by "Cyrillic", 4.15 kernels require both regulatory.db and the corresponding PKCS#7 signature. Straight to stable as per the precedent set by previous commits from Richard "Zero-Chaos" Farina. Closes: https://bugs.gentoo.org/643520 Package-Manager: Portage-2.3.19, Repoman-2.3.6 RepoMan-Options: --force
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wireless-regdb/wireless-regdb-20171223-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-wireless/wireless-regdb/wireless-regdb-20171223-r1.ebuild b/net-wireless/wireless-regdb/wireless-regdb-20171223-r1.ebuild
new file mode 100644
index 00000000000..23973a6371c
--- /dev/null
+++ b/net-wireless/wireless-regdb/wireless-regdb-20171223-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="wireless-regdb-${PV:0:4}.${PV:4:2}.${PV:6:2}"
+DESCRIPTION="Binary regulatory database for CRDA"
+HOMEPAGE="https://wireless.kernel.org/en/developers/Regulatory"
+SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${MY_P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ einfo "Recompiling regulatory.bin from db.txt would break CRDA verify. Installing unmodified binary version."
+}
+
+src_install() {
+ # This file is not ABI-specific, and crda itself always hardcodes
+ # this path. So install into a common location for all ABIs to use.
+ insinto /usr/lib/crda
+ doins regulatory.bin
+
+ insinto /etc/wireless-regdb/pubkeys
+ doins sforshee.key.pub.pem
+
+ # Linux 4.15 now complains if the firmware loader
+ # can't find these files #643520
+ insinto /lib/firmware
+ doins regulatory.db
+ doins regulatory.db.p7s
+
+ doman regulatory.bin.5
+ dodoc README db.txt
+}