summaryrefslogtreecommitdiff
path: root/net-wireless
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-02-19 11:49:35 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-02-19 12:29:17 -0500
commitc7517743c6a9a18aa26f4698da82b0a5bc52e2c9 (patch)
tree1225d5dab5de84256a14660b5e7dff294d9333bc /net-wireless
parent8e2b5cbf7d6d2341d46ebc9ef9efb4b56a881a20 (diff)
downloadgentoo-c7517743c6a9a18aa26f4698da82b0a5bc52e2c9.tar.gz
gentoo-c7517743c6a9a18aa26f4698da82b0a5bc52e2c9.tar.xz
net-wireless/soapyhackrf: import from pentoo
module for soapysdr Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/soapyhackrf/Manifest1
-rw-r--r--net-wireless/soapyhackrf/metadata.xml15
-rw-r--r--net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild26
-rw-r--r--net-wireless/soapyhackrf/soapyhackrf-9999.ebuild26
4 files changed, 68 insertions, 0 deletions
diff --git a/net-wireless/soapyhackrf/Manifest b/net-wireless/soapyhackrf/Manifest
new file mode 100644
index 00000000000..f926d707536
--- /dev/null
+++ b/net-wireless/soapyhackrf/Manifest
@@ -0,0 +1 @@
+DIST soapyhackrf-0.3.2.tar.gz 15643 BLAKE2B e57a0e2bc50984434f0e97207f8b274cc08d84e5884f4bee523614adb07d10cee810f1dd43d771f8b3a97bdb0dd84a0ac6b34d840aa9c93df19f7777f658d8d4 SHA512 667f27491d5fe18a04670ff0ade32b4a6f696ba8718e211957c7f8bab64957023ee4905df22214524ae3796a350a725d4f192fde21bb3d60cb9e69a4e629df90
diff --git a/net-wireless/soapyhackrf/metadata.xml b/net-wireless/soapyhackrf/metadata.xml
new file mode 100644
index 00000000000..2633b05296f
--- /dev/null
+++ b/net-wireless/soapyhackrf/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pothosware/SoapyHackRF</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild b/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild
new file mode 100644
index 00000000000..b5dece6d665
--- /dev/null
+++ b/net-wireless/soapyhackrf/soapyhackrf-0.3.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="SoapySDR HackRF module"
+HOMEPAGE="https://github.com/pothosware/SoapyHackRF"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyHackRF.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyHackRF/archive/soapy-hackrf-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyHackRF-soapy-hackrf-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libhackrf:="
+DEPEND="${RDEPEND}"
diff --git a/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild b/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild
new file mode 100644
index 00000000000..b5dece6d665
--- /dev/null
+++ b/net-wireless/soapyhackrf/soapyhackrf-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="SoapySDR HackRF module"
+HOMEPAGE="https://github.com/pothosware/SoapyHackRF"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyHackRF.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pothosware/SoapyHackRF/archive/soapy-hackrf-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyHackRF-soapy-hackrf-"${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr
+ net-libs/libhackrf:="
+DEPEND="${RDEPEND}"