summaryrefslogtreecommitdiff
path: root/sys-devel
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-30 19:07:56 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-15 13:47:23 +0100
commitff80562c7707b0a4d836c0b8b498dfc48cdedb9a (patch)
tree45070467ed84d2899a9213cd42707a14f30ebfb5 /sys-devel
parent38368fa1b651054b97a272104ab7350a6e73b819 (diff)
downloadgentoo-ff80562c7707b0a4d836c0b8b498dfc48cdedb9a.tar.gz
gentoo-ff80562c7707b0a4d836c0b8b498dfc48cdedb9a.tar.xz
sys-devel/lld: Support building against slotted LLVM
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/lld/lld-4.0.0_rc1.ebuild4
-rw-r--r--sys-devel/lld/lld-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/lld/lld-4.0.0_rc1.ebuild b/sys-devel/lld/lld-4.0.0_rc1.ebuild
index cb624392d7a..f927da85e4f 100644
--- a/sys-devel/lld/lld-4.0.0_rc1.ebuild
+++ b/sys-devel/lld/lld-4.0.0_rc1.ebuild
@@ -9,7 +9,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1
+inherit cmake-utils llvm python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="http://llvm.org/"
@@ -38,6 +38,7 @@ python_check_deps() {
}
pkg_setup() {
+ LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
use test && python-any-r1_pkg_setup
}
@@ -50,7 +51,6 @@ src_unpack() {
}
src_configure() {
- local libdir=$(get_libdir)
local mycmakeargs=(
# TODO: fix rpaths
#-DBUILD_SHARED_LIBS=ON
diff --git a/sys-devel/lld/lld-9999.ebuild b/sys-devel/lld/lld-9999.ebuild
index b4f23d3031e..b6ef4ad0436 100644
--- a/sys-devel/lld/lld-9999.ebuild
+++ b/sys-devel/lld/lld-9999.ebuild
@@ -9,7 +9,7 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-r3 python-any-r1
+inherit cmake-utils git-r3 llvm python-any-r1
DESCRIPTION="The LLVM linker (link editor)"
HOMEPAGE="http://llvm.org/"
@@ -34,6 +34,7 @@ python_check_deps() {
}
pkg_setup() {
+ llvm_pkg_setup
use test && python-any-r1_pkg_setup
}
@@ -53,7 +54,6 @@ src_unpack() {
}
src_configure() {
- local libdir=$(get_libdir)
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON