summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-12-13 10:14:30 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-12-13 10:14:30 -0600
commit1ff5ae9ce7a5e5d950b559fa835067ca03b6180d (patch)
tree03a6d6346dbe18502f2dfb28bab89a613ee866ed /www-apps
parentbec3a6922bd9e71b4ea0383199c380302f89f9b0 (diff)
downloadgentoo-1ff5ae9ce7a5e5d950b559fa835067ca03b6180d.tar.gz
gentoo-1ff5ae9ce7a5e5d950b559fa835067ca03b6180d.tar.xz
www-apps/icingaweb2: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.4.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 01460404778..a257478148e 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.3.3.tar.gz 9822506 SHA256 4f315f4a2099ab9562b2076e8f3e7e14562644b6cb62c9aa24adefc76b3f8f77 SHA512 864dc6c466c77413ef1674a60edc621f68ab1c72030b832391d457a19417278f7812f6e6fb0424862ebf6bc37ff1562521987a1d05b01b090a8994a1c61907fe WHIRLPOOL 671f3e14982f1618a91d4c029ebf4133ea3fc56b8bafb3fb2350b7feb1c885aae54db06fe0de7864674a6862cc0bd63fc26bd7d3d62b62e18e2c37e07ec3df81
DIST icingaweb2-2.3.4.tar.gz 9822451 SHA256 31b7a4b7a40587d18f7eb743686e8b1ccaee95a0b5c58baee2ea8f29b57e64ab SHA512 abfb556f6b27982524db9a6283af4fe7d5d6c559b4d15309477721d372760723c29588214c8147288c81784af75c2254d2b90563739cd68b9c9109326f9ed128 WHIRLPOOL 384a52d5f499c5e2befee78dd26a700682297ab24eeddc634849701745dcdbc88b0421a2574d4d11fc613c72b3f5146074c6395ac99aae488f2d150e42a05d67
+DIST icingaweb2-2.4.0.tar.gz 7177228 SHA256 aa8c1b2a0e655aa646045cb39c9db054fcb59bd0cac6751934f5b246aa067696 SHA512 f2c22e268d7920bccb1be0bb4d177fefebbb4aa87d4e50ba4e80f9f475b2e52b9c6f5fe0624f812eec89d3e5e6a0f77f41d237b8badf52b074571397ff77dc8d WHIRLPOOL 223aa88ce9a91eecb7430ba91bb0511f90578436f4b9f640a01857f0946d95e5e8e2b67bb0672914f96d269160c81bc986bb8c9b2d3bb574622b82c531a419fc
diff --git a/www-apps/icingaweb2/icingaweb2-2.4.0.ebuild b/www-apps/icingaweb2/icingaweb2-2.4.0.ebuild
new file mode 100644
index 00000000000..0da8152fa38
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.4.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}