summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/behave/Manifest1
-rw-r--r--dev-python/behave/behave-1.2.4.ebuild55
-rw-r--r--dev-python/behave/behave-1.2.5.ebuild52
3 files changed, 0 insertions, 108 deletions
diff --git a/dev-python/behave/Manifest b/dev-python/behave/Manifest
index e1f17344cf0..1a6ec6e3b47 100644
--- a/dev-python/behave/Manifest
+++ b/dev-python/behave/Manifest
@@ -1,2 +1 @@
-DIST behave-1.2.4.tar.gz 343050 BLAKE2B 5257ae5b735f60160939c0ba6112046103b5ecf47362a56a0d350b825f16d3bac1efe7d7ab330af26c8e117d1be243ab55f35c814dcba185a9168ee6547db35f SHA512 98360202fdccaa6cdfaf70a2a658db06b8de0017fbaeb5bd8d33ae8f009444a29f9e75eab8a4b363eb7719ef10566fad5521372285f2998cfb6e3037df706a1c
DIST behave-1.2.5.tar.gz 385738 BLAKE2B 0474d6442339ea263cbbc58a3d4ce86bd576d3b4a9e46cc14ebf9b722a07c4d85f7203791bab427188d24ffc75b92011dac3c967503177cae4e0d26d25d171c2 SHA512 137ede0baed9df154087249df8dcae81ab0cdf1de91a5790fca7ccf3231ba2ba4e64623abd2b8c9bfc459ab6575f68b9ef7e03e33ef79e524d9443a8489ec7fe
diff --git a/dev-python/behave/behave-1.2.4.ebuild b/dev-python/behave/behave-1.2.4.ebuild
deleted file mode 100644
index 92b9cdd4e69..00000000000
--- a/dev-python/behave/behave-1.2.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="behaviour-driven development, Python style"
-HOMEPAGE="https://github.com/behave/behave"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- doc? (
- >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/nose-1.1[${PYTHON_USEDEP}]
- >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "nosetests failed under ${EPYTHON}"
-
- rm -f "${HOME}"/.pydistutils.cfg || die "Couldn't remove pydistutils.cfg"
-
- distutils_install_for_testing
-
- ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail features/ || die "behave features failed under ${EPYTHON}"
- ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
- ${TEST_DIR}/scripts/behave -f progress --junit --tags=~@xfail issue.features/ || die "behave issue.features failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/docs/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/behave/behave-1.2.5.ebuild b/dev-python/behave/behave-1.2.5.ebuild
deleted file mode 100644
index 431484a1858..00000000000
--- a/dev-python/behave/behave-1.2.5.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="behaviour-driven development, Python style"
-HOMEPAGE="https://github.com/behave/behave"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/nose-1.3[${PYTHON_USEDEP}]
- >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- >=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
- >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests || die "nosetests failed under ${EPYTHON}"
-
- ${PYTHON} -m behave --tags='~@xfail' features/ || die "behave features failed under ${EPYTHON}"
- ${PYTHON} -m behave --tags='~@xfail' tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
- ${PYTHON} -m behave --tags='~@xfail' issue.features/ || die "behave issue.features failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/docs/html/. )
-
- distutils-r1_python_install_all
-}