summaryrefslogtreecommitdiff
path: root/app-office/grisbi
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/grisbi')
-rw-r--r--app-office/grisbi/Manifest1
-rw-r--r--app-office/grisbi/grisbi-1.0.0.ebuild38
-rw-r--r--app-office/grisbi/metadata.xml18
3 files changed, 57 insertions, 0 deletions
diff --git a/app-office/grisbi/Manifest b/app-office/grisbi/Manifest
new file mode 100644
index 00000000000..1f32e2a09b4
--- /dev/null
+++ b/app-office/grisbi/Manifest
@@ -0,0 +1 @@
+DIST grisbi-1.0.0.tar.bz2 6933736 SHA256 8a23d26777666814d918702ad9207bac433abd3ac71568d53f7c485670f92c55 SHA512 ec99f78cc4e6a7d3501bb40914491fc7a539c337e27f3360d84bcaff05bfa06dcd949f52177a7d2661cbc785ea9b27d3587cd4858363dc08a8daffac1015d77a WHIRLPOOL a3563bd20a428614f25fbefcf3f7f7835bb3ee32a2987699f01795bd6a66aba0df98ff7f0c139adf36d849ac91de98c75d0ab6b64775080c94e9ce50262eebc6
diff --git a/app-office/grisbi/grisbi-1.0.0.ebuild b/app-office/grisbi/grisbi-1.0.0.ebuild
new file mode 100644
index 00000000000..fb64b225e65
--- /dev/null
+++ b/app-office/grisbi/grisbi-1.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Grisbi is a personal accounting application for Linux"
+HOMEPAGE="http://www.grisbi.org"
+SRC_URI="mirror://sourceforge/grisbi/grisbi%20stable/1.0.x/${P}.tar.bz2"
+IUSE="nls ofx ssl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="dev-libs/libxml2
+ >=dev-libs/glib-2.18.0:2
+ >=x11-libs/gtk+-2.12.0:2
+ x11-misc/xdg-utils
+ ssl? ( >=dev-libs/openssl-0.9.5 )
+ ofx? ( >=dev-libs/libofx-0.7.0 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ G2CONF+="--with-libxml2
+ --without-cunit
+ --disable-static
+ $(use_with ssl openssl)
+ $(use_with ofx)
+ $(use_enable nls)"
+ DOCS="AUTHORS NEWS README"
+}
diff --git a/app-office/grisbi/metadata.xml b/app-office/grisbi/metadata.xml
new file mode 100644
index 00000000000..927ccdcbd1b
--- /dev/null
+++ b/app-office/grisbi/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>remi@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>casta@xwing.info</email>
+ <name>Guillaume Castagnino</name>
+ <description>Third party maintainer, through the gnome-office herd
+ as a proxy</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">grisbi</remote-id>
+ </upstream>
+</pkgmetadata>