summaryrefslogtreecommitdiff
path: root/dev-ml/cppo/cppo-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cppo/cppo-0.9.3.ebuild')
-rw-r--r--dev-ml/cppo/cppo-0.9.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/cppo/cppo-0.9.3.ebuild b/dev-ml/cppo/cppo-0.9.3.ebuild
new file mode 100644
index 00000000000..ab205a97c75
--- /dev/null
+++ b/dev-ml/cppo/cppo-0.9.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}