summaryrefslogtreecommitdiff
path: root/dev-ml/enumerate/enumerate-111.08.00.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/enumerate/enumerate-111.08.00.ebuild')
-rw-r--r--dev-ml/enumerate/enumerate-111.08.00.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/enumerate/enumerate-111.08.00.ebuild b/dev-ml/enumerate/enumerate-111.08.00.ebuild
new file mode 100644
index 00000000000..a77f6461707
--- /dev/null
+++ b/dev-ml/enumerate/enumerate-111.08.00.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension to produce a list of all values of a type"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-ml/type-conv-111.13:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( README.md )