summaryrefslogtreecommitdiff
path: root/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fort/files/fort-0.4.2-ocaml4.patch')
-rw-r--r--dev-ml/fort/files/fort-0.4.2-ocaml4.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/fort/files/fort-0.4.2-ocaml4.patch b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
new file mode 100644
index 00000000000..1c688a99544
--- /dev/null
+++ b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
@@ -0,0 +1,22 @@
+Index: fort-0.4.2/Makefile
+===================================================================
+--- fort-0.4.2.orig/Makefile
++++ fort-0.4.2/Makefile
+@@ -3,7 +3,7 @@
+
+ include Makefile.config
+
+-OCAMLC := ocamlc
++OCAMLC := ocamlc -I +compiler-libs
+
+ # FORT top-level interpreter
+ NAME := fort
+@@ -16,7 +16,7 @@ LIBS := unix
+ EXECUTABLE := $(NAME)$(EXEC_SUFFIX)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(OCAMLC) -linkall -o $@ toplevellib.cma $(LIBS:%=%.cma) $(OBJECTS)
++ $(OCAMLC) -linkall -o $@ ocamlcommon.cma ocamlbytecomp.cma ocamltoplevel.cma $(LIBS:%=%.cma) $(OBJECTS)
+
+ install: $(EXECUTABLE) $(OBJECTS)
+ mkdir -p $(DESTDIR)$(LIBDIR)