summaryrefslogtreecommitdiff
path: root/dev-ml/kaputt/kaputt-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/kaputt/kaputt-1.2.ebuild')
-rw-r--r--dev-ml/kaputt/kaputt-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/kaputt/kaputt-1.2.ebuild b/dev-ml/kaputt/kaputt-1.2.ebuild
new file mode 100644
index 00000000000..854656c9899
--- /dev/null
+++ b/dev-ml/kaputt/kaputt-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Unit testing tool for the Objective Caml language"
+HOMEPAGE="http://kaputt.x9c.fr/"
+SRC_URI="http://kaputt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ chmod +x configure
+ ./configure || die
+}
+
+src_compile() {
+ emake all
+}
+
+src_test() {
+ emake -j1 tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README FEATURES CHANGES
+}