summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild')
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild
new file mode 100644
index 00000000000..13183f5b507
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="http://forge.ocamlcore.org/projects/odn"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1029/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/type-conv-108.07.01:="
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] dev-ml/ocaml-fileutils[ocamlopt?] )"
+
+DOCS=( "README.txt" "AUTHORS.txt" "CHANGES.txt" )
+
+src_prepare() {
+ sed -i -e 's/type-conv/type_conv/' tests/test.ml || die
+}