summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild')
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
new file mode 100644
index 00000000000..168330a2e76
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="http://forge.ocamlcore.org/projects/odn"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1310/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/type-conv-108.07.01:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-2.0.0[ocamlopt?] dev-ml/ocaml-fileutils[ocamlopt?] )"
+
+DOCS=( "README.txt" "AUTHORS.txt" "CHANGES.txt" )