summaryrefslogtreecommitdiff
path: root/dev-ml/ocamldap/ocamldap-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamldap/ocamldap-2.2.ebuild')
-rw-r--r--dev-ml/ocamldap/ocamldap-2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocamldap/ocamldap-2.2.ebuild b/dev-ml/ocamldap/ocamldap-2.2.ebuild
new file mode 100644
index 00000000000..65f3f4ca0ba
--- /dev/null
+++ b/dev-ml/ocamldap/ocamldap-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="an implementation of the Light Weight Directory Access Protocol"
+HOMEPAGE="http://git-jpdeplaix.dyndns.org/libs/ocamldap.git/"
+SRC_URI="http://bitbucket.org/deplai_j/${PN}/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="dev-ml/pcre-ocaml:=
+ dev-ml/ocaml-ssl:=
+ dev-ml/ocamlnet:="
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS.txt Changelog INSTALL.txt README.txt )
+
+PATCHES=( "${FILESDIR}/ocaml-4.02.patch" )
+
+src_install() {
+ oasis_src_install
+ use doc && dohtml -r doc/ocamldap/html
+}