summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild')
-rw-r--r--dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
new file mode 100644
index 00000000000..e7bfd54fc74
--- /dev/null
+++ b/dev-ml/ocamlgsl/ocamlgsl-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base findlib
+
+DESCRIPTION="OCaml bindings for the GSL library"
+HOMEPAGE="http://oandrieu.nerim.net/ocaml/gsl/"
+SRC_URI="http://oandrieu.nerim.net/ocaml/gsl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/ocaml-3.10:=
+ sci-libs/gsl"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/fort )"
+
+PATCHES=( "${FILESDIR}/${P}-ocaml311.patch" )
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install-findlib
+
+ dodoc README NEWS NOTES
+ doinfo *.info*
+ if use doc; then
+ dohtml doc/*
+ fi
+}