summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlpam/ocamlpam-1.1.ebuild')
-rw-r--r--dev-ml/ocamlpam/ocamlpam-1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocamlpam/ocamlpam-1.1.ebuild b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
new file mode 100644
index 00000000000..b2b67cd9ac2
--- /dev/null
+++ b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCamlPAM - an OCaml library for PAM"
+HOMEPAGE="http://sharvil.nanavati.net/projects/ocamlpam/"
+SRC_URI="http://sharvil.nanavati.net/projects/${PN}/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake META
+ emake byte
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${OCAMLFIND_DESTDIR}" install
+ use ocamlopt && emake DESTDIR="${OCAMLFIND_DESTDIR}" install-opt
+ dodoc CHANGES README
+}