summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch')
-rw-r--r--dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch b/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch
new file mode 100644
index 00000000000..393391fe52c
--- /dev/null
+++ b/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch
@@ -0,0 +1,19 @@
+Index: ocamlweb-1.37/Makefile.in
+===================================================================
+--- ocamlweb-1.37.orig/Makefile.in
++++ ocamlweb-1.37/Makefile.in
+@@ -61,14 +61,12 @@ byte: ocamlweb.byte
+
+ ocamlweb: $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+ $(CAMLCOPT) $(OPTFLAGS) -o $@ $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+- strip ocamlweb
+
+ ocamlweb.byte: $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+ $(CAMLC) $(BYTEFLAGS) -o $@ $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+
+ ocamlweb.static: $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+ $(CAMLCOPT) $(OPTFLAGS) -cclib -static -o $@ $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+- strip $@
+
+ debug: $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+ $(CAMLC) $(BYTEFLAGS) -o ocamlweb-debug $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)