summaryrefslogtreecommitdiff
path: root/dev-ml/pomap/pomap-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pomap/pomap-3.0.2.ebuild')
-rw-r--r--dev-ml/pomap/pomap-3.0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pomap/pomap-3.0.2.ebuild b/dev-ml/pomap/pomap-3.0.2.ebuild
new file mode 100644
index 00000000000..343e225d8ac
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/pomap"
+SRC_URI="http://bitbucket.org/mmottl/pomap/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}