summaryrefslogtreecommitdiff
path: root/dev-ml/res/res-4.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/res/res-4.0.4.ebuild')
-rw-r--r--dev-ml/res/res-4.0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/res/res-4.0.4.ebuild b/dev-ml/res/res-4.0.4.ebuild
new file mode 100644
index 00000000000..5fec1470f25
--- /dev/null
+++ b/dev-ml/res/res-4.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://bitbucket.org/mmottl/res"
+SRC_URI="https://bitbucket.org/mmottl/res/downloads/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}