summaryrefslogtreecommitdiff
path: root/dev-ml/typehashlib/typehashlib-109.15.02.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/typehashlib/typehashlib-109.15.02.ebuild')
-rw-r--r--dev-ml/typehashlib/typehashlib-109.15.02.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/typehashlib/typehashlib-109.15.02.ebuild b/dev-ml/typehashlib/typehashlib-109.15.02.ebuild
new file mode 100644
index 00000000000..818974b3286
--- /dev/null
+++ b/dev-ml/typehashlib/typehashlib-109.15.02.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Syntax extension for deriving 'typehash' functions automatically"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/type-conv-${PV}:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"