summaryrefslogtreecommitdiff
path: root/dev-ml/xml-light/xml-light-2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/xml-light/xml-light-2.2-r1.ebuild')
-rw-r--r--dev-ml/xml-light/xml-light-2.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/xml-light/xml-light-2.2-r1.ebuild b/dev-ml/xml-light/xml-light-2.2-r1.ebuild
new file mode 100644
index 00000000000..b2f8489ad20
--- /dev/null
+++ b/dev-ml/xml-light/xml-light-2.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="Minimal Xml parser and printer for OCaml"
+HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
+SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ dev-lang/ocaml
+ doc? ( dev-ml/ocaml-doc )"
+RDEPEND="dev-lang/ocaml"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_compile() {
+ emake -j1
+ if use doc;then
+ emake doc
+ fi
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml install
+ dodoc README
+ if use doc; then
+ emake doc
+ dohtml doc/*
+ fi
+}