summaryrefslogtreecommitdiff
path: root/dev-ml/xmlm/xmlm-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/xmlm/xmlm-1.2.0.ebuild')
-rw-r--r--dev-ml/xmlm/xmlm-1.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/xmlm/xmlm-1.2.0.ebuild b/dev-ml/xmlm/xmlm-1.2.0.ebuild
new file mode 100644
index 00000000000..1c139cccc53
--- /dev/null
+++ b/dev-ml/xmlm/xmlm-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Ocaml XML manipulation module"
+HOMEPAGE="http://erratique.ch/software/xmlm"
+SRC_URI="http://erratique.ch/software/${PN}/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ pkg/build \
+ $(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc CHANGES.md README.md
+ use doc && dohtml doc/*
+}