summaryrefslogtreecommitdiff
path: root/dev-php
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Mail_Mime/Manifest1
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.0.ebuild23
-rw-r--r--dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.9.0.ebuild2
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch74
-rw-r--r--dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch74
-rw-r--r--dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch76
6 files changed, 25 insertions, 225 deletions
diff --git a/dev-php/PEAR-Mail_Mime/Manifest b/dev-php/PEAR-Mail_Mime/Manifest
index 250e3767b80..5af1cbc4c53 100644
--- a/dev-php/PEAR-Mail_Mime/Manifest
+++ b/dev-php/PEAR-Mail_Mime/Manifest
@@ -1,2 +1,3 @@
+DIST Mail_Mime-1.10.0.tgz 35767 SHA256 40867f312a7cc2bde95ea78a905bf8c7ded2dfe97b184dea43c21bf6ea5fd7eb SHA512 7fe54db4b0dee1ab3186d9ba8d4e5be02ddbcef530f1a3b70e509ca43ef0e4516ba8e829ba4397a30a703fcdbf42de36c10c204269ffa8be5d5f254e8929c9d6 WHIRLPOOL 357d00fe30e19c31580ef45b496ed893523216c8928a08298a8f9af400eba4f0a5f0a1c888be6095c2c68251dba670eeddaf771012b4cf84370e0b3970147917
DIST Mail_Mime-1.8.8.tgz 32059 SHA256 d1a7fb767ebdabef6b8d346911a0f91fc2bb23df36175cf036474f5ed942ced1 SHA512 c2d9735041f61ca7b7addbf4deae09e6b7448f3d34143fe10d49152802f100db2c29dcf9e8938010f275c38630b849c8e45bb2db54eed6504e8425669a18d0b8 WHIRLPOOL 573133f646decf3f88728c80c381efb1b4d307575c33bed6b53eb09f0b313352813b5364081be39166dcd7335480f89e6c861599b9f894aa083bc88614c6b39b
DIST Mail_Mime-1.9.0.tgz 35042 SHA256 17ee289990ab8f0b62d9806a5e094f4b130b9ba75e939f3496be9d9d9f3506d0 SHA512 915084166943be396603cc63736818fd4401e21b417d159cb47cf22c0de4153a7ecc4496c192212ac5c952196a35a56936def16305fb69beec64582994574fb7 WHIRLPOOL 9b279d872aa881301256f021d256fdc6701c54c52400f085c45641fcb056577ecb90d61c3a63dccf4195459f2f861d9afdb522986bb61edf2b1b559edfcd2764
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.0.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.0.ebuild
new file mode 100644
index 00000000000..f5bd01523fa
--- /dev/null
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit php-pear-r1
+
+DESCRIPTION="Create and manipulate mime messages with PHP"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+src_test() {
+ # Requires the "pear" executable from dev-php/PEAR-PEAR.
+ pear run-tests tests || die
+
+ # The command succeeds regardless of whether or not the test suite
+ # passed, but this file is only written when there was a failure.
+ [[ -f run-tests.log ]] && die "test suite failed"
+}
diff --git a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.9.0.ebuild b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.9.0.ebuild
index a9fa38e3f88..8f073e6397c 100644
--- a/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.9.0.ebuild
+++ b/dev-php/PEAR-Mail_Mime/PEAR-Mail_Mime-1.9.0.ebuild
@@ -10,7 +10,7 @@ DESCRIPTION="Provides classes to deal with creation and manipulation of mime mes
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
IUSE=""
DEPEND=">=dev-lang/php-5.0:*"
diff --git a/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
deleted file mode 100644
index b18e4c64251..00000000000
--- a/dev-php/PEAR-Mail_Mime/files/1.5.2-php-pass-by-reference-fix.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- mime.php.orig 2007-08-16 12:16:47.000000000 +0200
-+++ mime.php 2007-08-16 12:25:07.000000000 +0200
-@@ -376,7 +376,7 @@
- * @return string contents of $file_name
- * @access private
- */
-- function &_file2str($file_name)
-+ function _file2str($file_name)
- {
- if (!is_readable($file_name)) {
- $err = PEAR::raiseError('File is not readable ' . $file_name);
-@@ -413,7 +413,7 @@
- * @return object The text mimePart object
- * @access private
- */
-- function &_addTextPart(&$obj, $text)
-+ function _addTextPart(&$obj, $text)
- {
- $params['content_type'] = 'text/plain';
- $params['encoding'] = $this->_build_params['text_encoding'];
-@@ -437,7 +437,7 @@
- * @return object The html mimePart object
- * @access private
- */
-- function &_addHtmlPart(&$obj)
-+ function _addHtmlPart(&$obj)
- {
- $params['content_type'] = 'text/html';
- $params['encoding'] = $this->_build_params['html_encoding'];
-@@ -459,7 +459,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addMixedPart()
-+ function _addMixedPart()
- {
- $params = array();
- $params['content_type'] = 'multipart/mixed';
-@@ -480,7 +480,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addAlternativePart(&$obj)
-+ function _addAlternativePart(&$obj)
- {
- $params['content_type'] = 'multipart/alternative';
- if (is_object($obj)) {
-@@ -502,7 +502,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addRelatedPart(&$obj)
-+ function _addRelatedPart(&$obj)
- {
- $params['content_type'] = 'multipart/related';
- if (is_object($obj)) {
-@@ -523,7 +523,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addHtmlImagePart(&$obj, $value)
-+ function _addHtmlImagePart(&$obj, $value)
- {
- $params['content_type'] = $value['c_type'];
- $params['encoding'] = 'base64';
-@@ -546,7 +546,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addAttachmentPart(&$obj, $value)
-+ function _addAttachmentPart(&$obj, $value)
- {
- $params['dfilename'] = $value['name'];
- $params['encoding'] = $value['encoding'];
diff --git a/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
deleted file mode 100644
index ab87c19287e..00000000000
--- a/dev-php/PEAR-Mail_Mime/files/1.8.3-php-pass-by-reference-fix.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- a/Mail/mime.php.orig 2007-08-16 12:16:47.000000000 +0200
-+++ b/Mail/mime.php 2007-08-16 12:25:07.000000000 +0200
-@@ -376,7 +376,7 @@
- * @return string contents of $file_name
- * @access private
- */
-- function &_file2str($file_name)
-+ function _file2str($file_name)
- {
- if (!is_readable($file_name)) {
- $err = PEAR::raiseError('File is not readable ' . $file_name);
-@@ -413,7 +413,7 @@
- * @return object The text mimePart object
- * @access private
- */
-- function &_addTextPart(&$obj, $text)
-+ function _addTextPart(&$obj, $text)
- {
- $params['content_type'] = 'text/plain';
- $params['encoding'] = $this->_build_params['text_encoding'];
-@@ -437,7 +437,7 @@
- * @return object The html mimePart object
- * @access private
- */
-- function &_addHtmlPart(&$obj)
-+ function _addHtmlPart(&$obj)
- {
- $params['content_type'] = 'text/html';
- $params['encoding'] = $this->_build_params['html_encoding'];
-@@ -459,7 +459,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addMixedPart()
-+ function _addMixedPart()
- {
- $params = array();
- $params['content_type'] = 'multipart/mixed';
-@@ -480,7 +480,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addAlternativePart(&$obj)
-+ function _addAlternativePart(&$obj)
- {
- $params['content_type'] = 'multipart/alternative';
- if (is_object($obj)) {
-@@ -502,7 +502,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addRelatedPart(&$obj)
-+ function _addRelatedPart(&$obj)
- {
- $params['content_type'] = 'multipart/related';
- if (is_object($obj)) {
-@@ -523,7 +523,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addHtmlImagePart(&$obj, $value)
-+ function _addHtmlImagePart(&$obj, $value)
- {
- $params['content_type'] = $value['c_type'];
- $params['encoding'] = 'base64';
-@@ -546,7 +546,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addAttachmentPart(&$obj, $value)
-+ function _addAttachmentPart(&$obj, $value)
- {
- $params['dfilename'] = $value['name'];
- $params['encoding'] = $value['encoding'];
diff --git a/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch b/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch
deleted file mode 100644
index 677e67117a3..00000000000
--- a/dev-php/PEAR-Mail_Mime/files/php-pass-by-reference-fix.patch
+++ /dev/null
@@ -1,76 +0,0 @@
---- mime.php 2005-07-13 22:49:04.000000000 +0200
-+++ mime.php 2006-03-07 12:22:41.000000000 +0100
-@@ -309,7 +309,7 @@
- * @return object The text mimePart object
- * @access private
- */
-- function &_addTextPart(&$obj, $text)
-+ function _addTextPart(&$obj, $text)
- {
- $params['content_type'] = 'text/plain';
- $params['encoding'] = $this->_build_params['text_encoding'];
-@@ -330,7 +330,7 @@
- * @return object The html mimePart object
- * @access private
- */
-- function &_addHtmlPart(&$obj)
-+ function _addHtmlPart(&$obj)
- {
- $params['content_type'] = 'text/html';
- $params['encoding'] = $this->_build_params['html_encoding'];
-@@ -350,7 +350,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addMixedPart()
-+ function _addMixedPart()
- {
- $params['content_type'] = 'multipart/mixed';
- return new Mail_mimePart('', $params);
-@@ -366,7 +366,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addAlternativePart(&$obj)
-+ function _addAlternativePart(&$obj)
- {
- $params['content_type'] = 'multipart/alternative';
- if (is_object($obj)) {
-@@ -386,7 +386,7 @@
- * @return object The multipart/mixed mimePart object
- * @access private
- */
-- function &_addRelatedPart(&$obj)
-+ function _addRelatedPart(&$obj)
- {
- $params['content_type'] = 'multipart/related';
- if (is_object($obj)) {
-@@ -405,7 +405,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addHtmlImagePart(&$obj, $value)
-+ function _addHtmlImagePart(&$obj, $value)
- {
- $params['content_type'] = $value['c_type'];
- $params['encoding'] = 'base64';
-@@ -424,7 +424,7 @@
- * @return object The image mimePart object
- * @access private
- */
-- function &_addAttachmentPart(&$obj, $value)
-+ function _addAttachmentPart(&$obj, $value)
- {
- $params['content_type'] = $value['c_type'];
- $params['encoding'] = $value['encoding'];
---- mimePart.php 2004-12-11 00:08:26.000000000 +0100
-+++ mimePart.php 2006-03-07 12:22:41.000000000 +0100
-@@ -261,7 +261,7 @@
- * otherwise you will not be able to add further subparts.
- * @access public
- */
-- function &addSubPart($body, $params)
-+ function addSubPart($body, $params)
- {
- $this->_subparts[] = new Mail_mimePart($body, $params);
- return $this->_subparts[count($this->_subparts) - 1];