summaryrefslogtreecommitdiff
path: root/dev-python/patch/patch-1.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/patch/patch-1.16.ebuild')
-rw-r--r--dev-python/patch/patch-1.16.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-python/patch/patch-1.16.ebuild b/dev-python/patch/patch-1.16.ebuild
index 7c917ccb318..1c022279c33 100644
--- a/dev-python/patch/patch-1.16.ebuild
+++ b/dev-python/patch/patch-1.16.ebuild
@@ -6,26 +6,18 @@ EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit python-r1
+inherit distutils-r1
DESCRIPTION="Library to parse and apply unified diffs"
HOMEPAGE="https://github.com/techtonik/python-patch/"
-SRC_URI="https://github.com/techtonik/python-patch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
-S="${WORKDIR}/python-${P}"
-
-src_test() {
- python_foreach_impl tests/run_tests.py
-}
-
-src_install() {
- default
- python_foreach_impl python_doexe patch.py
-}
+S="${WORKDIR}"