summaryrefslogtreecommitdiff
path: root/dev-python/pycparser
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/pycparser-2.14-r1.ebuild34
-rw-r--r--dev-python/pycparser/pycparser-2.14.ebuild4
2 files changed, 2 insertions, 36 deletions
diff --git a/dev-python/pycparser/pycparser-2.14-r1.ebuild b/dev-python/pycparser/pycparser-2.14-r1.ebuild
deleted file mode 100644
index d479b06b766..00000000000
--- a/dev-python/pycparser/pycparser-2.14-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="C parser and AST generator written in Python"
-HOMEPAGE="https://github.com/eliben/pycparser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="test"
-
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_compile() {
- distutils-r1_python_compile
- pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die
- "${PYTHON}" _build_tables.py || die
- popd > /dev/null || die
-}
-
-python_test() {
- nosetests || die
-}
diff --git a/dev-python/pycparser/pycparser-2.14.ebuild b/dev-python/pycparser/pycparser-2.14.ebuild
index 0b29b2dad40..c7fc55640f5 100644
--- a/dev-python/pycparser/pycparser-2.14.ebuild
+++ b/dev-python/pycparser/pycparser-2.14.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1 vcs-snapshot