summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 98deedf0d9f..aa7cf5a5b93 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -157,7 +157,7 @@ exportmakeopts() {
myopts+=" NO_CURL=YesPlease"
fi
- # broken assumptions, because of broken build system ...
+ # broken assumptions, because of static build system ...
myopts+=" NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
myopts+=" INSTALL=install TAR=tar"
myopts+=" SHELL_PATH=${EPREFIX}/bin/sh"
@@ -219,7 +219,8 @@ exportmakeopts() {
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=" NEEDS_LIBICONV=YesPlease"
myopts+=" HAVE_CLOCK_MONOTONIC=1"
- myopts+=" HAVE_GETDELIM=1"
+ grep -q getdelim "${ROOT}"/usr/include/stdio.h && \
+ myopts+=" HAVE_GETDELIM=1"
fi
has_version '>=app-text/asciidoc-8.0' \