summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/weechat-1.9.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-irc/weechat/weechat-1.9.1.ebuild b/net-irc/weechat/weechat-1.9.1.ebuild
index 666fe3804e7..0597605d4a5 100644
--- a/net-irc/weechat/weechat-1.9.1.ebuild
+++ b/net-irc/weechat/weechat-1.9.1.ebuild
@@ -96,10 +96,13 @@ src_prepare() {
# install docs in correct directory
sed -i "s#\${SHAREDIR}/doc/\${PROJECT_NAME}#\0-${PV}/html#" doc/*/CMakeLists.txt || die
- # fix linking error on Darwin
if [[ ${CHOST} == *-darwin* ]]; then
+ # fix linking error on Darwin
sed -i "s/+ get_config_var('LINKFORSHARED')//" \
cmake/FindPython.cmake || die
+ # allow to find the plugins by default
+ sed -i 's/".so,.dll"/".bundle,.so,.dll"/' \
+ src/core/wee-config.c || die
fi
}