summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent-rasterbar
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.10.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index adec638e701..afcec93d7b2 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,3 +1,2 @@
-DIST libtorrent-rasterbar-1.0.10.tar.gz 3324494 SHA256 a865ceaca8b14acdd7be56d361ce4e64361299647e157ef7b3ac7e2812ca4c3e SHA512 08976239ec12e2d67a974dadf3f16330f48e4b6de314f9d97c5fbbdbc696b76b6b1f8e20ceab6830d46d17b1bfd7e2fe4048fb1a5a97ece12c242c0cd0f7ded2 WHIRLPOOL 1e4ef2fb41eef0b825bd7c8c665638e3f689c3cefca3caa18a01c328caad9d31cd417fb49d25a7d55da6457a89e35a891427d70fb4f4d070c74be2e2e0347a60
DIST libtorrent-rasterbar-1.0.11.tar.gz 3325786 SHA256 828d686770346f6da2c143c5a2844c5f5e407eb4a37982e90022763508abd62f SHA512 770d16b241174ae4b121af9b2ac7bcde8b14c6ed99352b827b760a3cbdc2c0ebd0d505319762897720c5f72acdff506ee9948ac1140e6d4591805eca5439b184 WHIRLPOOL e56bfe0830cfc7776436552171b14b08913d99a2c726c9eefa828027caaa96d9c3d97e6442a3b53f315eaa3e7e0f68175d813dbab1d6de1da5937054fc6cac9c
DIST libtorrent-rasterbar-1.1.5.tar.gz 3942894 SHA256 103134068389155a0f2bccaca72a57765460eb8188495089dcad280dcf426930 SHA512 d0e7fe944c8a396aaf79ce80c7513be07a855bc8a9eee3bca46ed83d5e190aaa5ea4dc9a8a7208e27e18ae8f15733e6e34eabd375f0bde43d4dc4607840782e7 WHIRLPOOL 1f78afceb67a69418d2afac915616812fe3a223c548ba2baf7e643fc5e63c79bd87998473ac4b6cab6ac0093d7f43ac91bcfba41c9d6ce0fc1ac46914fce74d2
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.10.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.10.ebuild
deleted file mode 100644
index b5f9a0b3953..00000000000
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.10.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-PYTHON_REQ_USE="threads"
-DISTUTILS_OPTIONAL=true
-DISTUTILS_IN_SOURCE_BUILD=true
-
-inherit distutils-r1 eutils versionator
-
-MY_PV=$(replace_all_version_separators _)
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://libtorrent.org"
-SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/8"
-KEYWORDS="amd64 arm ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug +dht doc examples +geoip libressl python +ssl static-libs test"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost:=[threads]
- virtual/libiconv
- examples? ( !net-p2p/mldonkey )
- geoip? ( dev-libs/geoip )
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/libtool
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.9-test_torrent_parse.patch"
- # master branch
- "${FILESDIR}/${PN}-1.0.11-fix-test_ssl.patch"
-)
-
-src_prepare() {
- default
-
- # bug 578026
- # prepend -L${S}/... to ensure bindings link against the lib we just built
- sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/compile_flags.in || die
-
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable debug logging)
- $(use_enable debug statistics)
- $(use_enable debug disk-stats)
- $(use_enable dht dht $(usex debug logging yes))
- $(use_enable examples)
- $(use_enable geoip)
- $(use_with geoip libgeoip)
- $(use_enable ssl encryption)
- $(use_enable static-libs static)
- $(use_enable test tests)
- --with-libiconv
- )
- econf "${myeconfargs[@]}"
-
- if use python; then
- myeconfargs+=(
- --enable-python-binding
- --with-boost-python
- )
- python_configure() {
- econf "${myeconfargs[@]}"
- }
- distutils-r1_src_configure
- fi
-}
-
-src_compile() {
- default
-
- python_compile() {
- cd "${BUILD_DIR}/../bindings/python" || die
- distutils-r1_python_compile
- }
- use python && distutils-r1_src_compile
-}
-
-src_install() {
- use doc && HTML_DOCS+=( "${S}"/docs )
-
- default
-
- python_install() {
- cd "${BUILD_DIR}/../bindings/python" || die
- distutils-r1_python_install
- }
- use python && distutils-r1_src_install
-
- prune_libtool_files
-}