summaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild (renamed from net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild)8
-rw-r--r--net-p2p/go-ethereum/metadata.xml1
2 files changed, 7 insertions, 2 deletions
diff --git a/net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild b/net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild
index e5c4fb7ef62..28bfc26b14b 100644
--- a/net-p2p/go-ethereum/go-ethereum-1.4.17.ebuild
+++ b/net-p2p/go-ethereum/go-ethereum-1.4.17-r1.ebuild
@@ -11,12 +11,16 @@ SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="evm"
+IUSE="evm opencl"
-DEPEND="dev-lang/go:="
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
RDEPEND="${DEPEND}"
src_compile() {
+ use opencl && export GO_OPENCL=true
+
emake geth
use evm && emake evm
}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
index d5433102321..8a476b0cf13 100644
--- a/net-p2p/go-ethereum/metadata.xml
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -11,5 +11,6 @@
</maintainer>
<use>
<flag name="evm">Build Ethereum Virtual Machine (EVM)</flag>
+ <flag name="opencl">Add OpenCL GPU mining support</flag>
</use>
</pkgmetadata>