summaryrefslogtreecommitdiff
path: root/sys-process/psmisc/psmisc-22.21-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/psmisc/psmisc-22.21-r2.ebuild')
-rw-r--r--sys-process/psmisc/psmisc-22.21-r2.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-process/psmisc/psmisc-22.21-r2.ebuild b/sys-process/psmisc/psmisc-22.21-r2.ebuild
deleted file mode 100644
index a2894e7d08d..00000000000
--- a/sys-process/psmisc/psmisc-22.21-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="A set of tools that use the proc filesystem"
-HOMEPAGE="http://psmisc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
-IUSE="ipv6 nls selinux X"
-
-RDEPEND=">=sys-libs/ncurses-5.7-r7
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2.2.6b
- nls? ( sys-devel/gettext )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-fuser_typo_fix.patch"
- epatch "${FILESDIR}/${P}-sysmacros.patch"
-}
-
-src_configure() {
- econf \
- $(use_enable selinux) \
- --disable-harden-flags \
- $(use_enable ipv6) \
- $(use_enable nls)
-}
-
-src_compile() {
- # peekfd is a fragile crap hack #330631
- nonfatal emake -C src peekfd || touch src/peekfd{.o,}
- emake
-}
-
-src_install() {
- default
-
- use X || rm -f "${ED}"/usr/bin/pstree.x11
-
- [[ -s ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/bin/peekfd
- [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
-
- # fuser is needed by init.d scripts; use * wildcard for #458250
- dodir /bin
- mv "${ED}"/usr/bin/*fuser "${ED}"/bin || die
-}