From af6161b28465e7d681dc639e3cca7471769674e3 Mon Sep 17 00:00:00 2001
From: Brian Evans <grknight@gentoo.org>
Date: Thu, 17 Sep 2015 14:19:34 -0400
Subject: dev-db/mysql++: Version bump

Package-Manager: portage-2.2.20.1
---
 dev-db/mysql++/mysql++-3.2.2.ebuild | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 dev-db/mysql++/mysql++-3.2.2.ebuild

(limited to 'dev-db/mysql++/mysql++-3.2.2.ebuild')

diff --git a/dev-db/mysql++/mysql++-3.2.2.ebuild b/dev-db/mysql++/mysql++-3.2.2.ebuild
new file mode 100644
index 00000000000..a5b37f6f65b
--- /dev/null
+++ b/dev-db/mysql++/mysql++-3.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="C++ API interface to the MySQL database"
+HOMEPAGE="http://tangentsoft.net/mysql++/"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/libmysqlclient:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+	epatch "${FILESDIR}/${PN}-3.2.1-gold.patch"
+	epatch_user
+}
+
+src_configure() {
+	local myconf="--enable-thread-check --with-mysql=${EPREFIX}/usr"
+	econf ${myconf}
+}
+
+src_install() {
+	default
+	# install the docs and HTML pages
+	dodoc CREDITS* HACKERS.txt Wishlist doc/ssqls-pretty
+	dodoc -r doc/pdf/ doc/refman/ doc/userman/
+	dohtml -r doc/html/
+}
-- 
cgit v1.2.1