From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 .../common-lisp-controller-5.13-r1.ebuild          | 97 ++++++++++++++++++++++
 1 file changed, 97 insertions(+)
 create mode 100644 dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild

(limited to 'dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild')

diff --git a/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild b/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
new file mode 100644
index 00000000000..a4dfe46ee55
--- /dev/null
+++ b/dev-lisp/common-lisp-controller/common-lisp-controller-5.13-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="Common Lisp Controller"
+HOMEPAGE="http://packages.debian.org/unstable/devel/common-lisp-controller"
+SRC_URI="mirror://gentoo/common-lisp-controller_${PV}.tar.gz"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="|| ( >=sys-apps/coreutils-8.15 app-misc/realpath )
+	>=dev-lisp/asdf-1.84
+	dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+	unpack ${A}
+	cd "${S}/man"
+	ln -s clc-{,un}register-user-package.1
+	for i in unregister-common-lisp-implementation {,un}register-common-lisp-source; do
+		ln -s register-common-lisp-implementation.8 ${i}.8
+	done
+}
+
+src_install() {
+	dobin clc-register-user-package
+	dobin clc-unregister-user-package
+	dosbin register-common-lisp-implementation
+	dosbin register-common-lisp-source
+	dosbin unregister-common-lisp-implementation
+	dosbin unregister-common-lisp-source
+
+	dosbin clc-update-customized-images
+	keepdir /etc/common-lisp/images
+
+	insinto /usr/share/common-lisp/source/common-lisp-controller
+	doins common-lisp-controller.lisp post-sysdef-install.lisp
+	doman man/*.[138]
+	insinto /etc
+	doins "${FILESDIR}/${PV}/lisp-config.lisp"
+	dodoc "${FILESDIR}/README.Gentoo"
+	dodoc DESIGN.txt debian/changelog
+}
+
+pkg_postinst() {
+	test -d /var/cache/common-lisp-controller \
+		|| mkdir /var/cache/common-lisp-controller
+	chmod 1777 /var/cache/common-lisp-controller
+
+	# This code from ${S}/debian/postinst
+
+	for compiler in /usr/lib/common-lisp/bin/*.sh
+	do
+		if [ -f "${compiler}" -a -r "${compiler}" -a -x "${compiler}" ] ; then
+			i=${compiler##*/}
+			i=${i%.sh}
+			einfo ">>> Recompiling Common Lisp Controller for $i"
+			bash "$compiler" install-clc || true
+			einfo ">>> Done rebuilding"
+		fi
+	done
+
+	# This code from ${S}/debian/preinst
+
+	# cleanup fasl files:
+	( find /usr/share/common-lisp/source/defsystem \
+		/usr/share/common-lisp/source/asdf \
+		/usr/share/common-lisp/source/common-lisp-controller -type f -not -name "*.lisp" -print0 \
+		| xargs --null rm --force 2> /dev/null ) &>/dev/null
+
+	# remove old autobuild files:
+#	find /etc/common-lisp -name autobuild -print0 \
+#		| xargs -0 rm 2> /dev/null || true
+#	find /etc/common-lisp -type d -depth -print0 \
+#		| xargs rmdir 2> /dev/null || true
+
+	# remove old fals files:
+	test -d /usr/lib/common-lisp-controller \
+		&& rmdir --ignore-fail-on-non-empty /usr/lib/common-lisp-controller
+	for compiler in /usr/lib/common-lisp/bin/*.sh ; do
+		if [ -f "$compiler" -a -r "$compiler" ] ; then
+			i=${compiler##*/}
+			i=${i%.sh}
+			if [ -d "/usr/lib/common-lisp/${i}" ] ; then
+				rm -rf "/usr/lib/common-lisp/${i}"
+			fi
+		fi
+	done
+}
-- 
cgit v1.2.1