From 8274fff2a440e0272fe0d24a74aa41bd51ad8283 Mon Sep 17 00:00:00 2001
From: Patrick Lauer <patrick@gentoo.org>
Date: Sat, 16 Sep 2017 14:47:53 +0000
Subject: dev-python/flask-script: Bump

Package-Manager: Portage-2.3.8, Repoman-2.3.3
---
 dev-python/flask-script/flask-script-2.0.6.ebuild | 40 +++++++++++++++++++++++
 1 file changed, 40 insertions(+)
 create mode 100644 dev-python/flask-script/flask-script-2.0.6.ebuild

(limited to 'dev-python/flask-script/flask-script-2.0.6.ebuild')

diff --git a/dev-python/flask-script/flask-script-2.0.6.ebuild b/dev-python/flask-script/flask-script-2.0.6.ebuild
new file mode 100644
index 00000000000..58fd2a94576
--- /dev/null
+++ b/dev-python/flask-script/flask-script-2.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Script"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask support for writing external scripts"
+HOMEPAGE="http://packages.python.org/Flask-Script/ https://pypi.python.org/pypi/Flask-Script"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+	test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+	use doc && emake -C docs html
+}
+
+python_test() {
+	py.test tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+	use doc && local HTML_DOCS=( docs/_build/html/. )
+	distutils-r1_python_install_all
+}
-- 
cgit v1.2.1