From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-ruby/ruby-clutter/Manifest                     |  2 +
 dev-ruby/ruby-clutter/metadata.xml                 |  5 +++
 dev-ruby/ruby-clutter/ruby-clutter-2.2.3-r1.ebuild | 35 ++++++++++++++++
 dev-ruby/ruby-clutter/ruby-clutter-2.2.3.ebuild    | 35 ++++++++++++++++
 dev-ruby/ruby-clutter/ruby-clutter-2.2.5.ebuild    | 49 ++++++++++++++++++++++
 5 files changed, 126 insertions(+)
 create mode 100644 dev-ruby/ruby-clutter/Manifest
 create mode 100644 dev-ruby/ruby-clutter/metadata.xml
 create mode 100644 dev-ruby/ruby-clutter/ruby-clutter-2.2.3-r1.ebuild
 create mode 100644 dev-ruby/ruby-clutter/ruby-clutter-2.2.3.ebuild
 create mode 100644 dev-ruby/ruby-clutter/ruby-clutter-2.2.5.ebuild

(limited to 'dev-ruby/ruby-clutter')

diff --git a/dev-ruby/ruby-clutter/Manifest b/dev-ruby/ruby-clutter/Manifest
new file mode 100644
index 00000000000..eeb791e8efb
--- /dev/null
+++ b/dev-ruby/ruby-clutter/Manifest
@@ -0,0 +1,2 @@
+DIST ruby-gnome2-all-2.2.3.tar.gz 1657315 SHA256 1611038c2a49fe051dfcc779aeca8eb47273718d80a0680442504fd54e228154 SHA512 cf6b0c88c91e444f5ff65a4a863630c5455315c08f1b44a5f7c81db51f998d6e83ab62e00276edb4a81ea9942405d76724f52134d2388010ec0f157a6a5dc34e WHIRLPOOL e5a6347b360b64f6b690a28483f8618d58786bbbf1fd6c691952271c85bf1d96dc8c97f1e4ed541f6cf8afac56221950db30873cc83a24210b6feef969eaf4b7
+DIST ruby-gnome2-all-2.2.5.tar.gz 1696485 SHA256 ef22418c95ce9f997235aee1a1b4d1265fad023e78a8f452bdd9e95267dd52b9 SHA512 60693ec2db4c4159a634f33bf7021e078cc06e25d4e10c6ac0c8a30ac03f9b8119ed94d9b62408a2010c9c3d1f812dea3ab5c6c617eda5d4c73272d64934159e WHIRLPOOL 161ae5b591bd1b6ba3601d46bc4fcfa6c57b006bd5903ba5a8c7ec670f11e06091ce5314290e24b312ecb61ceef22fb91231079f03f16a873a4e890142389123
diff --git a/dev-ruby/ruby-clutter/metadata.xml b/dev-ruby/ruby-clutter/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/ruby-clutter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-clutter/ruby-clutter-2.2.3-r1.ebuild b/dev-ruby/ruby-clutter/ruby-clutter-2.2.3-r1.ebuild
new file mode 100644
index 00000000000..b3a44a29550
--- /dev/null
+++ b/dev-ruby/ruby-clutter/ruby-clutter-2.2.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Clutter bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+RUBY_S=ruby-gnome2-all-${PV}/clutter
+
+DEPEND+=" media-libs/clutter"
+RDEPEND+=" media-libs/clutter"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-cairo-gobject-${PV}
+	>=dev-ruby/ruby-gobject-introspection-${PV}"
+
+each_ruby_configure() {
+	:
+}
+
+each_ruby_compile() {
+	:
+}
+
+each_ruby_install() {
+	each_fakegem_install
+}
diff --git a/dev-ruby/ruby-clutter/ruby-clutter-2.2.3.ebuild b/dev-ruby/ruby-clutter/ruby-clutter-2.2.3.ebuild
new file mode 100644
index 00000000000..4cece3e8cc8
--- /dev/null
+++ b/dev-ruby/ruby-clutter/ruby-clutter-2.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Clutter bindings"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RESTRICT="test"
+
+RUBY_S=ruby-gnome2-all-${PV}/clutter
+
+DEPEND+=" media-libs/clutter"
+RDEPEND+=" media-libs/clutter"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-cairo-gobject-${PV}
+	>=dev-ruby/ruby-gobject-introspection-${PV}"
+
+each_ruby_configure() {
+	:
+}
+
+each_ruby_compile() {
+	:
+}
+
+each_ruby_install() {
+	each_fakegem_install
+}
diff --git a/dev-ruby/ruby-clutter/ruby-clutter-2.2.5.ebuild b/dev-ruby/ruby-clutter/ruby-clutter-2.2.5.ebuild
new file mode 100644
index 00000000000..995319ccfeb
--- /dev/null
+++ b/dev-ruby/ruby-clutter/ruby-clutter-2.2.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit virtualx ruby-ng-gnome2
+
+DESCRIPTION="Ruby Clutter bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RUBY_S=ruby-gnome2-all-${PV}/clutter
+
+DEPEND+=" media-libs/clutter"
+RDEPEND+=" media-libs/clutter"
+
+ruby_add_bdepend ">=dev-ruby/ruby-glib2-${PV}"
+ruby_add_rdepend ">=dev-ruby/ruby-cairo-gobject-${PV}
+	>=dev-ruby/ruby-gobject-introspection-${PV}"
+
+all_ruby_prepare() {
+	# Avoid unneeded dependency on test-unit-notify.
+	sed -i -e '/notify/ s:^:#:' \
+		../gobject-introspection/test/gobject-introspection-test-utils.rb \
+		../cairo-gobject/test/cairo-gobject-test-utils.rb \
+		test/clutter-test-utils.rb || die
+
+	# Avoid compilation of dependencies during test.
+	sed -i -e '/system/,/^  end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_configure() {
+	:
+}
+
+each_ruby_compile() {
+	:
+}
+
+each_ruby_test() {
+	VIRTUALX_COMMAND="${RUBY} test/run-test.rb"
+	virtualmake || die
+}
+
+each_ruby_install() {
+	each_fakegem_install
+}
-- 
cgit v1.2.1