From 6de4e36846c583f1188325c6a424c5acadee8c4a Mon Sep 17 00:00:00 2001
From: Zero_Chaos <zerochaos@gentoo.org>
Date: Sun, 6 Sep 2015 17:25:35 -0400
Subject: net-libs/libbtbb;net-wireless/{kismet-,}ubertooth: new release, plus
 rx_only firmware

---
 net-libs/libbtbb/Manifest                 |   2 +-
 net-libs/libbtbb/libbtbb-2015.09.1.ebuild | 133 ------------------------------
 net-libs/libbtbb/libbtbb-2015.09.2.ebuild | 133 ++++++++++++++++++++++++++++++
 3 files changed, 134 insertions(+), 134 deletions(-)
 delete mode 100644 net-libs/libbtbb/libbtbb-2015.09.1.ebuild
 create mode 100644 net-libs/libbtbb/libbtbb-2015.09.2.ebuild

(limited to 'net-libs/libbtbb')

diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index a537b8088d3..a6cf8153f10 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1 +1 @@
-DIST libbtbb-2015-09-R1.tar.gz 222558 SHA256 6f68eae9f8504facce33c42ee790a4ba5dbc79d89564c9a10e9e25b6eb8328b1 SHA512 30b8e376fe4be0e0a5856256cff17f889f154ff7c76ab359cab3eb62bf7f3defc9bae00150a332954f10e60a5cbb84e0ae4595f5298fe3333235b8f6b252990b WHIRLPOOL 1805eb41f7cf4814c3d2f689157b22efd25f8a5dc12f2eb407d61487bd3d270bd630b3b9c54a8e65aa523a8538d61405661267fdffc1975b42ebd4b4b6f4d84c
+DIST libbtbb-2015-09-R2.tar.gz 222045 SHA256 35ce44636649163f0d9a4de5905f686470f54c79b408959760db8c8182853161 SHA512 e300ec09de34644a0cd2f4aba2fe0b03021aaa0b0fe5035022f1e698ff10867adfd84850d0d40e9c070fbd622efee1b614221c1f5b1818f1d4f5d58cc3f31919 WHIRLPOOL 99d8c621b263cd3cd82e423eabff21d4979b0407c31430aa26424d273c9e3ed802e68833e3a100588a46a9a2126a84d0be56e41c1b609ea2eed4a3d64203c995
diff --git a/net-libs/libbtbb/libbtbb-2015.09.1.ebuild b/net-libs/libbtbb/libbtbb-2015.09.1.ebuild
deleted file mode 100644
index 3d12be1e26f..00000000000
--- a/net-libs/libbtbb/libbtbb-2015.09.1.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib cmake-utils
-
-DESCRIPTION="A library to decode Bluetooth baseband packets"
-HOMEPAGE="http://libbtbb.sourceforge.net/"
-
-if [[ ${PV} == "9999" ]] ; then
-	EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
-	inherit git-r3
-	KEYWORDS=""
-else
-	MY_PV=${PV/\./-}
-	MY_PV=${MY_PV/./-R}
-	S=${WORKDIR}/${PN}-${MY_PV}
-	SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
-	KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-IUSE="+pcap +wireshark-plugins"
-
-RDEPEND="
-	pcap? ( net-libs/libpcap )
-	wireshark-plugins? (
-		>=net-analyzer/wireshark-1.8.3-r1:=
-		!>net-analyzer/wireshark-1.98
-	)
-"
-DEPEND="${RDEPEND}
-	wireshark-plugins? ( dev-libs/glib
-			virtual/pkgconfig )"
-
-get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
-
-which_plugins() {
-	if has_version '>=net-analyzer/wireshark-1.12.0'; then
-		plugins="btbb btbredr"
-	elif has_version '<net-analyzer/wireshark-1.12.0'; then
-		plugins="btbb btle btsm"
-	fi
-}
-
-src_prepare(){
-	CMAKE_USE_DIR="${S}"
-	BUILD_DIR="${S}"_build
-	cmake-utils_src_prepare
-
-	if use wireshark-plugins; then
-		which_plugins
-		for i in ${plugins}
-		do
-			sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
-			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
-			BUILD_DIR="${WORKDIR}"/${i}_build
-			cmake-utils_src_prepare
-		done
-	fi
-}
-
-src_configure() {
-	CMAKE_USE_DIR="${S}"
-	BUILD_DIR="${S}"_build
-	local mycmakeargs=(
-		-DDISABLE_PYTHON=true
-		-DPACKAGE_MANAGER=true
-		$(cmake-utils_use pcap PCAPDUMP)
-		$(cmake-utils_use pcap USE_PCAP)
-	)
-	cmake-utils_src_configure
-
-	if use wireshark-plugins; then
-		for i in ${plugins}
-		do
-			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
-			BUILD_DIR="${WORKDIR}"/${i}_build
-			local mycmakeargs=(
-			-DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
-			)
-			cmake-utils_src_configure
-		done
-	fi
-}
-
-src_compile(){
-	CMAKE_USE_DIR="${S}"
-	BUILD_DIR="${S}"_build
-	cmake-utils_src_compile
-
-	if use wireshark-plugins; then
-		for i in ${plugins}
-		do
-			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
-			BUILD_DIR="${WORKDIR}"/${i}_build
-			cmake-utils_src_compile
-		done
-	fi
-}
-
-src_test(){
-	CMAKE_USE_DIR="${S}"
-	BUILD_DIR="${S}"_build
-	cmake-utils_src_test
-
-	if use wireshark-plugins; then
-		for i in ${plugins}
-		do
-			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
-			BUILD_DIR="${WORKDIR}"/${i}_build
-			cmake-utils_src_test
-		done
-	fi
-}
-
-src_install(){
-	CMAKE_USE_DIR="${S}"
-	BUILD_DIR="${S}"_build
-	cmake-utils_src_install
-
-	if use wireshark-plugins; then
-		for i in ${plugins}
-		do
-			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
-			BUILD_DIR="${WORKDIR}"/${i}_build
-			cmake-utils_src_install
-		done
-	fi
-}
diff --git a/net-libs/libbtbb/libbtbb-2015.09.2.ebuild b/net-libs/libbtbb/libbtbb-2015.09.2.ebuild
new file mode 100644
index 00000000000..3d12be1e26f
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2015.09.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib cmake-utils
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+	EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+	inherit git-r3
+	KEYWORDS=""
+else
+	MY_PV=${PV/\./-}
+	MY_PV=${MY_PV/./-R}
+	S=${WORKDIR}/${PN}-${MY_PV}
+	SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+	KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="+pcap +wireshark-plugins"
+
+RDEPEND="
+	pcap? ( net-libs/libpcap )
+	wireshark-plugins? (
+		>=net-analyzer/wireshark-1.8.3-r1:=
+		!>net-analyzer/wireshark-1.98
+	)
+"
+DEPEND="${RDEPEND}
+	wireshark-plugins? ( dev-libs/glib
+			virtual/pkgconfig )"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+which_plugins() {
+	if has_version '>=net-analyzer/wireshark-1.12.0'; then
+		plugins="btbb btbredr"
+	elif has_version '<net-analyzer/wireshark-1.12.0'; then
+		plugins="btbb btle btsm"
+	fi
+}
+
+src_prepare(){
+	CMAKE_USE_DIR="${S}"
+	BUILD_DIR="${S}"_build
+	cmake-utils_src_prepare
+
+	if use wireshark-plugins; then
+		which_plugins
+		for i in ${plugins}
+		do
+			sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
+			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+			BUILD_DIR="${WORKDIR}"/${i}_build
+			cmake-utils_src_prepare
+		done
+	fi
+}
+
+src_configure() {
+	CMAKE_USE_DIR="${S}"
+	BUILD_DIR="${S}"_build
+	local mycmakeargs=(
+		-DDISABLE_PYTHON=true
+		-DPACKAGE_MANAGER=true
+		$(cmake-utils_use pcap PCAPDUMP)
+		$(cmake-utils_use pcap USE_PCAP)
+	)
+	cmake-utils_src_configure
+
+	if use wireshark-plugins; then
+		for i in ${plugins}
+		do
+			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+			BUILD_DIR="${WORKDIR}"/${i}_build
+			local mycmakeargs=(
+			-DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
+			)
+			cmake-utils_src_configure
+		done
+	fi
+}
+
+src_compile(){
+	CMAKE_USE_DIR="${S}"
+	BUILD_DIR="${S}"_build
+	cmake-utils_src_compile
+
+	if use wireshark-plugins; then
+		for i in ${plugins}
+		do
+			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+			BUILD_DIR="${WORKDIR}"/${i}_build
+			cmake-utils_src_compile
+		done
+	fi
+}
+
+src_test(){
+	CMAKE_USE_DIR="${S}"
+	BUILD_DIR="${S}"_build
+	cmake-utils_src_test
+
+	if use wireshark-plugins; then
+		for i in ${plugins}
+		do
+			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+			BUILD_DIR="${WORKDIR}"/${i}_build
+			cmake-utils_src_test
+		done
+	fi
+}
+
+src_install(){
+	CMAKE_USE_DIR="${S}"
+	BUILD_DIR="${S}"_build
+	cmake-utils_src_install
+
+	if use wireshark-plugins; then
+		for i in ${plugins}
+		do
+			CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+			BUILD_DIR="${WORKDIR}"/${i}_build
+			cmake-utils_src_install
+		done
+	fi
+}
-- 
cgit v1.2.1