From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 net-print/cups-filters/Manifest                    |   2 +
 net-print/cups-filters/cups-filters-1.0.66.ebuild  | 120 ++++++++++++++++++++
 net-print/cups-filters/cups-filters-1.0.71.ebuild  | 122 +++++++++++++++++++++
 net-print/cups-filters/cups-filters-9999.ebuild    | 120 ++++++++++++++++++++
 net-print/cups-filters/files/cups-browsed.init.d   |  20 ++++
 net-print/cups-filters/files/cups-browsed.service  |  10 ++
 .../files/cups-filters-1.0.53-uclibc.patch         |  16 +++
 .../files/cups-filters-1.0.65-poppler0310.patch    |  65 +++++++++++
 .../files/cups-filters-1.0.71-poppler0340.patch    |  38 +++++++
 net-print/cups-filters/metadata.xml                |  10 ++
 10 files changed, 523 insertions(+)
 create mode 100644 net-print/cups-filters/Manifest
 create mode 100644 net-print/cups-filters/cups-filters-1.0.66.ebuild
 create mode 100644 net-print/cups-filters/cups-filters-1.0.71.ebuild
 create mode 100644 net-print/cups-filters/cups-filters-9999.ebuild
 create mode 100644 net-print/cups-filters/files/cups-browsed.init.d
 create mode 100644 net-print/cups-filters/files/cups-browsed.service
 create mode 100644 net-print/cups-filters/files/cups-filters-1.0.53-uclibc.patch
 create mode 100644 net-print/cups-filters/files/cups-filters-1.0.65-poppler0310.patch
 create mode 100644 net-print/cups-filters/files/cups-filters-1.0.71-poppler0340.patch
 create mode 100644 net-print/cups-filters/metadata.xml

(limited to 'net-print/cups-filters')

diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
new file mode 100644
index 00000000000..fbae5cc01b9
--- /dev/null
+++ b/net-print/cups-filters/Manifest
@@ -0,0 +1,2 @@
+DIST cups-filters-1.0.66.tar.xz 1335740 SHA256 a46eea35d8c151f1f63c663c5dda290ba11a7f5951d48dba485a02f9146dfb1c SHA512 275d704a52889fd0f18b9c1ed5aad70efd0df3b0beac30fca5467135d9c9b0ccc0ea7e3d1274086cf475c4a569262edc85962b5076df3ba2e9d3fe4d2c376fa2 WHIRLPOOL 040fe61f197187913c90e42a26ada1957e9289854627af3cceff984027fb630417b9e8548e3ca7d713a74ad0074389459a41de3bc7579438335a84e30a694ba5
+DIST cups-filters-1.0.71.tar.xz 1339116 SHA256 3180aa209c383402822e568ccef8e1ca43f51e30b3af2039c34ebae919a69c1f SHA512 dc243e88d535c8d7e7fd53074b1093a46fc22742504efa09096d2b216846df875e4d914f25d2f726034692538cfdf1b713bc1ef44d199003a21e242b99f44a01 WHIRLPOOL 4afc7079594563f57af81501192cc0cba19db6cd5c10a9544339858a343e245b485e528fbf80eecd711341b23b8321bde817c49db7ddd2f0b801da2b4b9c580d
diff --git a/net-print/cups-filters/cups-filters-1.0.66.ebuild b/net-print/cups-filters/cups-filters-1.0.66.ebuild
new file mode 100644
index 00000000000..9a43edca514
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.66.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+	inherit bzr
+	EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+	KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+else
+	SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+	KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+	>=app-text/ghostscript-gpl-9.09
+	app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+	>=app-text/qpdf-3.0.2:=
+	media-libs/fontconfig
+	media-libs/freetype:2
+	media-libs/lcms:2
+	>=net-print/cups-1.7.3
+	!<=net-print/cups-1.5.9999
+	sys-devel/bc
+	sys-libs/zlib
+	dbus? ( sys-apps/dbus )
+	foomatic? ( !net-print/foomatic-filters )
+	jpeg? ( virtual/jpeg:0 )
+	perl? ( dev-lang/perl:= )
+	png? ( media-libs/libpng:0= )
+	tiff? ( media-libs/tiff:0 )
+	zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+	base_src_prepare
+	sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--docdir="${EPREFIX}/usr/share/doc/${PF}" \
+		$(use_enable dbus) \
+		$(use_enable zeroconf avahi) \
+		$(use_enable static-libs static) \
+		--with-fontdir="fonts/conf.avail" \
+		--with-pdftops=pdftops \
+		--enable-imagefilters \
+		$(use_with jpeg) \
+		$(use_with png) \
+		$(use_with tiff) \
+		--with-rcdir=no \
+ 		--with-browseremoteprotocols=DNSSD,CUPS \
+		--without-php
+}
+
+src_compile() {
+	MAKEOPTS=-j1 default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_configure
+		perl-module_src_compile
+		popd > /dev/null
+	fi
+}
+
+src_install() {
+	default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_install
+		perl_delete_localpod
+		popd > /dev/null
+	fi
+
+	# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+	dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+	dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+	prune_libtool_files --all
+
+	cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+	if ! use zeroconf ; then
+		sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+		sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+	fi
+
+	if ! use foomatic ; then
+		# this needs an upstream solution / configure switch
+		rm -v "${ED}/usr/bin/foomatic-rip" || die
+		rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+		rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+	fi
+
+	doinitd "${T}"/cups-browsed
+	systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+	if ! use foomatic ; then
+		ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+		ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+	fi
+}
diff --git a/net-print/cups-filters/cups-filters-1.0.71.ebuild b/net-print/cups-filters/cups-filters-1.0.71.ebuild
new file mode 100644
index 00000000000..474f495cad0
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.71.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+	inherit bzr
+	EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+	KEYWORDS="alpha amd64 arm hppa ia64 ppc64 sparc x86"
+else
+	SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+	KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+	>=app-text/ghostscript-gpl-9.09
+	app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+	>=app-text/qpdf-3.0.2:=
+	media-libs/fontconfig
+	media-libs/freetype:2
+	media-libs/lcms:2
+	>=net-print/cups-1.7.3
+	!<=net-print/cups-1.5.9999
+	sys-devel/bc
+	sys-libs/zlib
+	dbus? ( sys-apps/dbus )
+	foomatic? ( !net-print/foomatic-filters )
+	jpeg? ( virtual/jpeg:0 )
+	perl? ( dev-lang/perl:= )
+	png? ( media-libs/libpng:0= )
+	tiff? ( media-libs/tiff:0 )
+	zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.71-poppler0340.patch" )
+
+src_prepare() {
+	base_src_prepare
+	sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--docdir="${EPREFIX}/usr/share/doc/${PF}" \
+		$(use_enable dbus) \
+		$(use_enable zeroconf avahi) \
+		$(use_enable static-libs static) \
+		--with-fontdir="fonts/conf.avail" \
+		--with-pdftops=pdftops \
+		--enable-imagefilters \
+		$(use_with jpeg) \
+		$(use_with png) \
+		$(use_with tiff) \
+		--with-rcdir=no \
+ 		--with-browseremoteprotocols=DNSSD,CUPS \
+		--without-php
+}
+
+src_compile() {
+	MAKEOPTS=-j1 default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_configure
+		perl-module_src_compile
+		popd > /dev/null
+	fi
+}
+
+src_install() {
+	default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_install
+		perl_delete_localpod
+		popd > /dev/null
+	fi
+
+	# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+	dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+	dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+	prune_libtool_files --all
+
+	cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+	if ! use zeroconf ; then
+		sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+		sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+	fi
+
+	if ! use foomatic ; then
+		# this needs an upstream solution / configure switch
+		rm -v "${ED}/usr/bin/foomatic-rip" || die
+		rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+		rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+	fi
+
+	doinitd "${T}"/cups-browsed
+	systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+	if ! use foomatic ; then
+		ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+		ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+	fi
+}
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
new file mode 100644
index 00000000000..84982d88086
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+	inherit bzr
+	EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+	KEYWORDS=""
+else
+	SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+	KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+	>=app-text/ghostscript-gpl-9.09
+	app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+	>=app-text/qpdf-3.0.2:=
+	media-libs/fontconfig
+	media-libs/freetype:2
+	media-libs/lcms:2
+	>=net-print/cups-1.7.3
+	!<=net-print/cups-1.5.9999
+	sys-devel/bc
+	sys-libs/zlib
+	dbus? ( sys-apps/dbus )
+	foomatic? ( !net-print/foomatic-filters )
+	jpeg? ( virtual/jpeg:0 )
+	perl? ( dev-lang/perl:= )
+	png? ( media-libs/libpng:0= )
+	tiff? ( media-libs/tiff:0 )
+	zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+	base_src_prepare
+	sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--docdir="${EPREFIX}/usr/share/doc/${PF}" \
+		$(use_enable dbus) \
+		$(use_enable zeroconf avahi) \
+		$(use_enable static-libs static) \
+		--with-fontdir="fonts/conf.avail" \
+		--with-pdftops=pdftops \
+		--enable-imagefilters \
+		$(use_with jpeg) \
+		$(use_with png) \
+		$(use_with tiff) \
+		--with-rcdir=no \
+ 		--with-browseremoteprotocols=DNSSD,CUPS \
+		--without-php
+}
+
+src_compile() {
+	MAKEOPTS=-j1 default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_configure
+		perl-module_src_compile
+		popd > /dev/null
+	fi
+}
+
+src_install() {
+	default
+
+	if use perl; then
+		pushd "${S}/scripting/perl" > /dev/null
+		perl-module_src_install
+		perl_delete_localpod
+		popd > /dev/null
+	fi
+
+	# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+	dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+	dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+	prune_libtool_files --all
+
+	cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+	if ! use zeroconf ; then
+		sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+		sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+	fi
+
+	if ! use foomatic ; then
+		# this needs an upstream solution / configure switch
+		rm -v "${ED}/usr/bin/foomatic-rip" || die
+		rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+		rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+	fi
+
+	doinitd "${T}"/cups-browsed
+	systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+	if ! use foomatic ; then
+		ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+		ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+	fi
+}
diff --git a/net-print/cups-filters/files/cups-browsed.init.d b/net-print/cups-filters/files/cups-browsed.init.d
new file mode 100644
index 00000000000..785c13a25d8
--- /dev/null
+++ b/net-print/cups-filters/files/cups-browsed.init.d
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+
+PIDFILE=/var/run/cups-browsed.pid
+
+depend() {
+	need cupsd avahi-daemon
+}
+
+start() {
+	ebegin "Starting cups-browsed"
+	start-stop-daemon --start --make-pidfile --pidfile "${PIDFILE}" \
+		--background --quiet --exec /usr/sbin/cups-browsed
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping cups-browsed"
+	start-stop-daemon --stop --pidfile "${PIDFILE}" --quiet --exec /usr/sbin/cupsd
+	eend $?
+}
diff --git a/net-print/cups-filters/files/cups-browsed.service b/net-print/cups-filters/files/cups-browsed.service
new file mode 100644
index 00000000000..144956c7fd2
--- /dev/null
+++ b/net-print/cups-filters/files/cups-browsed.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Make remote CUPS printers available locally
+After=cups.service avahi-daemon.service
+Wants=cups.service avahi-daemon.service
+
+[Service]
+ExecStart=/usr/sbin/cups-browsed
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-print/cups-filters/files/cups-filters-1.0.53-uclibc.patch b/net-print/cups-filters/files/cups-filters-1.0.53-uclibc.patch
new file mode 100644
index 00000000000..88e6c341f1f
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.0.53-uclibc.patch
@@ -0,0 +1,16 @@
+--- cups-filters-1.0.53/filter/foomatic-rip/foomaticrip.c
++++ cups-filters-1.0.53-uclibc/filter/foomatic-rip/foomaticrip.c
+@@ -736,8 +736,13 @@ int main(int argc, char** argv)
+         debug = 1;
+ 
+     if (debug) {
++#ifdef __UCLIBC__
++	sprintf(tmp, "%s-log-XXXXXX", LOG_FILE);
++	int fd = mkstemp (tmp);
++#else
+ 	sprintf(tmp, "%s-XXXXXX.log", LOG_FILE);
+ 	int fd = mkstemps (tmp, 4);
++#endif
+ 	if (fd != -1)
+ 	    logh = fdopen(fd, "w");
+ 	else
diff --git a/net-print/cups-filters/files/cups-filters-1.0.65-poppler0310.patch b/net-print/cups-filters/files/cups-filters-1.0.65-poppler0310.patch
new file mode 100644
index 00000000000..569d835cfe0
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.0.65-poppler0310.patch
@@ -0,0 +1,65 @@
+Source: http://www.linuxfromscratch.org/blfs/view/svn/pst/cups-filters.html
+
+Submitted By:            Armin K. <krejzi at email dot com>
+Date:                    2015-02-10
+Initial Package Version: 1.0.62
+Upstream Status:         Submitted
+Origin:                  Self
+Description:             Fixes building when using Poppler 0.31.x.
+
+--- a/filter/pdftoijs.cxx	2013-12-10 22:20:15.000000000 +0100
++++ b/filter/pdftoijs.cxx	2015-02-10 21:51:32.700190378 +0100
+@@ -436,7 +436,11 @@
+   }
+ 
+   out = new SplashOutputDev(cmode,rowpad/* row padding */,
+-    reverseVideo,paperColor,gTrue,gFalse);
++    reverseVideo,paperColor,gTrue
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR <= 30
++    ,gFalse
++#endif
++    );
+ #if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 19
+   out->startDoc(doc);
+ #else
+--- a/filter/pdftoopvp/OPVPOutputDev.cxx	2014-03-10 12:19:19.000000000 +0100
++++ b/filter/pdftoopvp/OPVPOutputDev.cxx	2015-02-10 21:52:09.092847693 +0100
+@@ -278,7 +278,11 @@
+ 				    gFalse,
+                                     gFalse,
+ #endif
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR <= 30
+ 				    globalParams->getAntialias());
++#else
++                                    gFalse);
++#endif
+   for (i = 0; i < nT3Fonts; ++i) {
+     delete t3FontCache[i];
+   }
+--- a/filter/pdftoopvp/pdftoopvp.cxx	2013-12-10 22:20:15.000000000 +0100
++++ b/filter/pdftoopvp/pdftoopvp.cxx	2015-02-10 21:51:32.701190397 +0100
+@@ -614,7 +614,9 @@
+       ok = gFalse;
+     }
+   }
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR <= 30
+   globalParams->setAntialias("no");
++#endif
+   if (quiet) {
+     globalParams->setErrQuiet(quiet);
+   }
+--- a/filter/pdftoraster.cxx	2014-09-26 18:23:04.000000000 +0200
++++ b/filter/pdftoraster.cxx	2015-02-10 21:51:32.701190397 +0100
+@@ -2100,7 +2100,11 @@
+   }
+ 
+   out = new SplashOutputDev(cmode,rowpad/* row padding */,
+-    gFalse,paperColor,gTrue,gFalse);
++    gFalse,paperColor,gTrue
++#if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR <= 30
++    ,gFalse
++#endif
++    );
+ #if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 19
+   out->startDoc(doc);
+ #else
diff --git a/net-print/cups-filters/files/cups-filters-1.0.71-poppler0340.patch b/net-print/cups-filters/files/cups-filters-1.0.71-poppler0340.patch
new file mode 100644
index 00000000000..ac0cae3bc7a
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.0.71-poppler0340.patch
@@ -0,0 +1,38 @@
+Hack to make this build against poppler-0.34. Just disables color management in some places.
+We should probably find a better solution. dilfridge@gentoo.org
+
+
+diff -ruN cups-filters-1.0.71.orig/filter/pdftoopvp/OPVPOutputDev.cxx cups-filters-1.0.71/filter/pdftoopvp/OPVPOutputDev.cxx
+--- cups-filters-1.0.71.orig/filter/pdftoopvp/OPVPOutputDev.cxx	2015-06-26 17:45:26.000000000 +0200
++++ cups-filters-1.0.71/filter/pdftoopvp/OPVPOutputDev.cxx	2015-07-14 19:02:51.666737621 +0200
+@@ -1812,9 +1812,15 @@
+   maskSplash->drawImage(&imageSrc, &imgMaskData,
+ 			splashModeMono8, gFalse, maskWidth, maskHeight, mat);
+ #else
++#if POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
+   maskSplash->drawImage(&imageSrc, &imgMaskData,
+ 			splashModeMono8, gFalse, maskWidth, maskHeight,
+                         mat,gFalse);
++#else
++  maskSplash->drawImage(&imageSrc, NULL, &imgMaskData,
++			splashModeMono8, gFalse, maskWidth, maskHeight,
++                        mat,gFalse);
++#endif
+ #endif
+   delete imgMaskData.imgStr;
+   maskStr->close();
+diff -ruN cups-filters-1.0.71.orig/filter/pdftoopvp/oprs/OPRS.cxx cups-filters-1.0.71/filter/pdftoopvp/oprs/OPRS.cxx
+--- cups-filters-1.0.71.orig/filter/pdftoopvp/oprs/OPRS.cxx	2015-06-26 17:45:26.000000000 +0200
++++ cups-filters-1.0.71/filter/pdftoopvp/oprs/OPRS.cxx	2015-07-14 19:00:20.655740720 +0200
+@@ -241,7 +241,11 @@
+ #if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
+ 	return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
+ #else
++#if POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
+ 	return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
++#else
++	return splash->drawImage(src,NULL,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
++#endif
+ #endif
+     } else {
+ 	return opvpSplash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
diff --git a/net-print/cups-filters/metadata.xml b/net-print/cups-filters/metadata.xml
new file mode 100644
index 00000000000..dec732cd7b4
--- /dev/null
+++ b/net-print/cups-filters/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>printing</herd>
+  <use>
+  <flag name='foomatic'>
+     Build the included foomatic-rip printer driver. Strongly recommended.
+  </flag>
+  </use>
+</pkgmetadata>
-- 
cgit v1.2.1