summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-09-07 10:14:46 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-09-07 10:14:46 -0600
commit9fc8c5f3fd2e1d661c9812c2b41090087d438586 (patch)
treebe8da3e60e40b2c5c3d8980e27833fd13dd1bb9a
parent0048b5494c59211f54f9c97a769da636ad297550 (diff)
downloadgentoo.patches-9fc8c5f3fd2e1d661c9812c2b41090087d438586.tar.gz
gentoo.patches-9fc8c5f3fd2e1d661c9812c2b41090087d438586.tar.xz
Add makefile with simple `install` target
Add a basic `Makefile` to document and capture the typical installation process of the patches. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..25f2ead
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,6 @@
+PATCHES_DIR:=patches/
+INSTALL_DIR?=/etc/portage/patches
+
+.PHONY: install
+install: $(PATCHES_DIR) $(PATCHES)
+ cp -r $< $(INSTALL_DIR)