summaryrefslogtreecommitdiff
path: root/dev-python/kitchen/kitchen-1.2.4.ebuild
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-09-06 17:13:35 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-09-06 17:13:35 -0600
commit6239f96c7f4c1fa8b007d10566ceb1eb12d9bd27 (patch)
tree0425a83b95be892b0513dfa7f69e78653700d51a /dev-python/kitchen/kitchen-1.2.4.ebuild
parent7b3ccce4ee5b490c35f89eb7e4b7f22d58cef191 (diff)
downloadkb-6239f96c7f4c1fa8b007d10566ceb1eb12d9bd27.tar.gz
kb-6239f96c7f4c1fa8b007d10566ceb1eb12d9bd27.tar.xz
dev-python: add packages from bugwarrior overlay
Add the several packages defined in the bugwarrior overlay. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
Diffstat (limited to 'dev-python/kitchen/kitchen-1.2.4.ebuild')
-rw-r--r--dev-python/kitchen/kitchen-1.2.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/kitchen/kitchen-1.2.4.ebuild b/dev-python/kitchen/kitchen-1.2.4.ebuild
new file mode 100644
index 0000000..8363fdd
--- /dev/null
+++ b/dev-python/kitchen/kitchen-1.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2016 Kenny Ballou
+# Distributed under the terms of the GNU General Public License v3
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_{3,4})
+
+inherit distutils-r1
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Kitchen contains a cornucopia of useful code"
+HOMEPAGE="https://fedorahosted.org/kitchen/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}